Skip to content

Commit

Permalink
dev-libs/ocl-icd: install directly into /usr
Browse files Browse the repository at this point in the history
This leaves x11-drivers/nvidia-drivers as the only OpenCL implementation
still requiring eselect-opencl.

Committed directly due to prolonged absence of the maintainer.

Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Apr 10, 2020
1 parent 06d9045 commit 3493e5e
Showing 1 changed file with 47 additions and 0 deletions.
47 changes: 47 additions & 0 deletions dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby24 ruby25 ruby26 ruby27"
inherit autotools flag-o-matic multilib-minimal ruby-single

DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
HOMEPAGE="https://github.com/OCL-dev/ocl-icd"
SRC_URI="https://github.com/OCL-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="+khronos-headers"

BDEPEND="${RUBY_DEPS}"
RDEPEND="!app-eselect/eselect-opencl
!dev-libs/opencl-icd-loader
!x11-drivers/nvidia-drivers"

PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)

src_prepare() {
replace-flags -Os -O2 # bug 646122

default
eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf --enable-pthread-once
}

multilib_src_install() {
default

# Drop .la files
find "${ED}" -name '*.la' -delete || die

# Install vendor headers
if use khronos-headers; then
insinto /usr/include
doins -r "${S}/khronos-headers/CL"
fi
}

0 comments on commit 3493e5e

Please sign in to comment.