Skip to content

Commit

Permalink
games-roguelike/FTL-gog: version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Closes: gentoo#7665
  • Loading branch information
kitsunenokenja authored and monsieurp committed Apr 2, 2018
1 parent aa2173a commit 3499912
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
61 changes: 61 additions & 0 deletions games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit desktop unpacker

DESCRIPTION="Top-down roguelike space ship simulator"
HOMEPAGE="https://www.gog.com/game/faster_than_light"
SRC_URI="ftl_advanced_edition_en_${PV//./_}.sh"
RESTRICT="bindist fetch mirror strip test"

LICENSE="GOG-EULA"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""

DEPEND="app-arch/unzip"
RDEPEND="media-libs/freetype
media-libs/libsdl[X,sound,opengl,video]
media-libs/libpng
sys-libs/zlib
virtual/opengl"

S="${WORKDIR}/data/noarch"

pkg_nofetch() {
elog "Please buy and download ${SRC_URI} from"
elog "https://www.gog.com/game/faster_than_light"
}

src_unpack() {
unpack_zip "${DISTDIR}/${A}"
}

src_prepare() {
default
rm -r support/{xdg*,*.{sh,txt}} || die
if ! use x86; then
rm game/data/FTL.x86 || die
fi
if ! use amd64; then
rm game/data/FTL.amd64 || die
fi
}

src_install() {
insinto /opt/gog/FTL
doins -r .
fperms +x /opt/gog/FTL/{start.sh,game/FTL}

if use x86; then
fperms +x /opt/gog/FTL/game/data/FTL.x86
fi
if use amd64; then
fperms +x /opt/gog/FTL/game/data/FTL.amd64
fi

make_desktop_entry "/opt/gog/FTL/start.sh" "FTL: Advanced Edition" FTL
newicon support/icon.png FTL.png
}
1 change: 1 addition & 0 deletions games-roguelike/FTL-gog/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ftl_advanced_edition_en_1_6_3_17917.sh 190333601 BLAKE2B 18fb43da1718524fcdecbde9d9cbfbed84db6e5b3a49abbec9b331d13f9ce7ca807633f3ad126badba9e92278b264ab3de47efabbf772180a35c108ce07268f1 SHA512 6cc3770d9a3d9ac301d79eaee0b88d3d4bbf90186356d443f53d4e894b4cdefd36c080e23506d76e0a3f7e15267e3e206469872cc7b29ddeaa20d520b9dfddd0
DIST ftl_advanced_edition_en_1_6_7_18662.sh 190506416 BLAKE2B 0a628e4de3a5539add2f421377c32ead5397ad1709e30124aa8c9d0874b98eb37cda97873b21dbb78fe635769c1a3c3254988ae22494805409d28f5e33417e44 SHA512 3e9c08d32964e21b49ad3e1b6a17c2349d516fdbea4118518e022134affc43dd27d2e60eea94784096aea4725f2656b43f6b6be9fe02eaed743c167ef842d66b

0 comments on commit 3499912

Please sign in to comment.