Skip to content

Commit

Permalink
dev-db/pgadmin3: Version Bump
Browse files Browse the repository at this point in the history
Version bump fixes bug 571452.

Bug: 571452

Package-Manager: portage-2.2.20.1
  • Loading branch information
titanofold committed Jan 11, 2016
1 parent 8728c90 commit 34a3de5
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/pgadmin3/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pgadmin3-1.18.1.tar.gz 14265392 SHA256 27ac3e296a6ca3da9da8ee22ed98eabfe1377be507877ffc26048fc2a9c6cbc0 SHA512 e292aaf95159eda98fe5f5112aad758cc08c38fe325ef92c698009defeb3891d9e0d485c00a0cbb82b70a95f54755eeb7f90b82a34354e77b485f738b5458c99 WHIRLPOOL 1f1af18a721c2c99b0dc52ec571e5831aac89eb998d9917e82134f9a900fce5b5a8edcc55640c962bd9b14de1ebae42cf9d896e1a3f84a05402674252dfeeb17
DIST pgadmin3-1.20.0.tar.gz 14394997 SHA256 0773d7826a9c7a998c4872e9b00b998e0bbb10448984d66853420c95fa626b8c SHA512 83521a16d60bf8c9cffb03e4fb401a31e28f764c31608c0b223f7c88a14a09f665c976f3472debd4ad8b6cd54f0fbd2b8de352c296180e6ea6f8088cb45447bc WHIRLPOOL 336e785e7ed6d67d129bba3230a73900cc8404ce29371d4a9ec1db98d2ceb4fb6fd60ea75a2b432c2fe1bbec886db76d9dbbc4ffe77b067709f8e250fa348fe7
DIST pgadmin3-1.22.0.tar.gz 14668096 SHA256 3c76c429797a9524f00d4dd82ab77aa367f2bba154c2b2e017de5cbc9d690256 SHA512 db16ac1b92e95a6da51be973b6833e53aed4c1d8740c8bccbfd778b0c3d3a4158fb13107761e0a39227aea87360be3b297ebc8809ac8ca5102d673935a33727c WHIRLPOOL 2282b70c4579f2ad5b83c94cfa62429f1825e387e5864db8cf74631b1bbd340d4031c6d5a50947c1fdd8a15c3b732fe69a90fef1c38fd109de9d5f3ae8d007ca
60 changes: 60 additions & 0 deletions dev-db/pgadmin3/pgadmin3-1.22.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils multilib versionator wxwidgets

DESCRIPTION="wxWidgets GUI for PostgreSQL"
HOMEPAGE="http://www.pgadmin.org/"
SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"

LICENSE="POSTGRESQL"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
SLOT="0"
IUSE="debug +databasedesigner"

DEPEND="x11-libs/wxGTK:=[X,debug=]
>=dev-db/postgresql-8.4.0:=
>=dev-libs/libxml2-2.6.18
>=dev-libs/libxslt-1.1"
RDEPEND="${DEPEND}"

pkg_setup() {
local pgslot=$(postgresql-config show)

if [[ ${pgslot//.} < 84 ]] ; then
eerror "PostgreSQL slot must be set to 8.4 or higher."
eerror " postgresql-config set 8.4"
die "PostgreSQL slot is not set to 8.4 or higher."
fi
}

src_prepare() {
epatch "${FILESDIR}/pgadmin3-desktop.patch"

epatch_user
}

src_configure() {
WX_GTK_PV=$(best_version x11-libs/wxGTK[X,debug=])
WX_GTK_VER=$(get_version_component_range 1-2 ${WX_GTK_PV#x11-libs/wxGTK-})

need-wxwidgets unicode

econf --with-wx-version=${WX_GTK_VER} \
$(use_enable debug) \
$(use_enable databasedesigner)
}

src_install() {
emake DESTDIR="${D}" install

newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png

domenu "${S}/pkg/pgadmin3.desktop"

# Fixing world-writable files
fperms -R go-w /usr/share
}

0 comments on commit 34a3de5

Please sign in to comment.