forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-fps/glxquake-bin: port to EAPI 7, games.eclass--, improve pkg_p…
…ostinst Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
872469e
commit 34b62e6
Showing
1 changed file
with
13 additions
and
15 deletions.
There are no files selected for viewing
28 changes: 13 additions & 15 deletions
28
...fps/glxquake-bin/glxquake-bin-0-r2.ebuild → ...fps/glxquake-bin/glxquake-bin-0-r3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,42 +1,40 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
inherit games | ||
EAPI=7 | ||
|
||
DESCRIPTION="A binary that works with any 3D-graphics-card that supports the glx X-extension" | ||
HOMEPAGE="http://mfcn.ilo.de/glxquake/" | ||
SRC_URI="http://www.wh-hms.uni-ulm.de/~mfcn/shared/glxquake/glxquake.tar.gz" | ||
S="${WORKDIR}"/glxquake | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="-* ~amd64 ~x86" | ||
RESTRICT="strip" | ||
IUSE="" | ||
|
||
RDEPEND="sys-libs/glibc | ||
RDEPEND=" | ||
sys-libs/glibc | ||
amd64? ( sys-libs/glibc[multilib] ) | ||
virtual/opengl[abi_x86_32(-)] | ||
x11-libs/libX11[abi_x86_32(-)] | ||
x11-libs/libXext[abi_x86_32(-)] | ||
x11-libs/libXxf86vm[abi_x86_32(-)] | ||
x11-libs/libXxf86dga[abi_x86_32(-)]" | ||
x11-libs/libXxf86dga[abi_x86_32(-)] | ||
" | ||
|
||
S=${WORKDIR}/glxquake | ||
|
||
QA_PREBUILT="${GAMES_BINDIR:1}/glquake" | ||
QA_PREBUILT="usr/bin/glquake" | ||
|
||
src_install() { | ||
dogamesbin glquake | ||
dobin glquake | ||
dodoc README | ||
prepgamesdirs | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
elog "To play with it, create a subdirectory called id1" | ||
elog "To play with ${PN}, create a subdirectory called id1" | ||
elog "Copy the pak0.pak, and eventually pak1.pak into this subdirectory" | ||
elog "You can eventually get pak0.pak emerging games-fps/quake1-demodata" | ||
elog "The file pak0.pak will be on the ${GAMES_DATADIR}/quake1/demo/" | ||
elog "You can get pak0.pa by emerging games-fps/quake1-demodata" | ||
elog "(or use the disc)" | ||
elog "The file pak0.pak will be in /usr/share/quake1/demo/" | ||
elog "You can now run glxquake by executing glquake" | ||
} |