Skip to content

Commit

Permalink
app-emulation/cloud-init: add 22.4
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/890742
Signed-off-by: Skyler Mäntysaari <[email protected]>
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
samip5 authored and prometheanfire committed Feb 6, 2023
1 parent 86bea57 commit 34c5cda
Show file tree
Hide file tree
Showing 2 changed files with 96 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/cloud-init/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cloud-init-22.2.2.tar.gz 1349451 BLAKE2B fdb6669e9762984614fefe787834f20f056345d304327679fa8bc7b4d6566509a23ecc4a7ac4e6368b9b9078a72fe6fe35533a67e7aeb0c0accbf5ad014f8aae SHA512 18b75ebbb5e808e19df5ceddb6402cc881c33443fb169f736f54837254ba43836994f2392a26febbd8df3342b3467ee72759b6942cfeb96d07c0e452c11dd0bf
DIST cloud-init-22.4.tar.gz 1494295 BLAKE2B 5f961c895c0d6c78a7cee47d2b52acd57d959baeb5172cea89d75ffe23424e3a8a3170a0ecdcad729c6cb0c898477ea94c43a5f8bdf200fc3f122c32fdb2e96d SHA512 6151d1d5e4be241219cb5804ca2bad2dd790f366bc847d286a8840faad1fb4adf5d780c9418ce574c2cfcefc16851a49961f33c5da1fbc84bb8299cf138bfcfc
95 changes: 95 additions & 0 deletions app-emulation/cloud-init/cloud-init-22.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,95 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# Disabled for now: bug #850628
# https://bugs.launchpad.net/cloud-init/+bug/1978328
#DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_11 )

inherit distutils-r1 udev

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
else
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
KEYWORDS="amd64 arm64 ppc64 x86"
fi

DESCRIPTION="Cloud instance initialisation magic"
HOMEPAGE="https://launchpad.net/cloud-init"

LICENSE="GPL-3"
SLOT="0"
IUSE="selinux test"
RESTRICT="!test? ( test )"

CDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/oauthlib[${PYTHON_USEDEP}]
dev-python/pyserial[${PYTHON_USEDEP}]
>=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/jsonpatch[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
dev-python/netifaces[${PYTHON_USEDEP}]
"
BDEPEND="
${CDEPEND}
test? (
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
)
"
RDEPEND="
${CDEPEND}
net-analyzer/macchanger
sys-apps/iproute2
sys-fs/growpart
virtual/logger
selinux? ( sec-policy/selinux-cloudinit )
"

distutils_enable_tests pytest

python_prepare_all() {
# Fix location of documentation installation
sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die

if [[ ${PV} == *9999 ]] ; then
sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
fi
distutils-r1_python_prepare_all
}

python_install() {
distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
}

python_install_all() {
keepdir /etc/cloud

distutils-r1_python_install_all

# installs as non-executable
chmod +x "${D}"/etc/init.d/* || die
}

pkg_prerm() {
udev_reload
}

pkg_postinst() {
udev_reload

elog "cloud-init-local needs to be run in the boot runlevel because it"
elog "modifies services in the default runlevel. When a runlevel is started"
elog "it is cached, so modifications that happen to the current runlevel"
elog "while you are in it are not acted upon."
}

0 comments on commit 34c5cda

Please sign in to comment.