Skip to content

Commit

Permalink
games-kids/tuxmath: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent dabb47a commit 34d30a2
Showing 1 changed file with 66 additions and 0 deletions.
66 changes: 66 additions & 0 deletions games-kids/tuxmath/tuxmath-2.0.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils gnome2-utils

MY_PN="${PN}_w_fonts"
DESCRIPTION="Educational arcade game where you have to solve maths problems"
HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/"
SRC_URI="mirror://debian/pool/main/t/${PN}/${PN}_${PV}.orig.tar.gz"

LICENSE="GPL-2 OFL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls svg"

RDEPEND="dev-games/t4k-common[svg?]
dev-libs/libxml2:2
media-libs/libsdl:0[video]
media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer[mod]
media-libs/sdl-net
media-libs/sdl-pango
nls? ( virtual/libintl )
svg? (
gnome-base/librsvg:2
x11-libs/cairo
)"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"

S=${WORKDIR}/${MY_PN}-${PV}

src_prepare() {
default

sed -i -e '/\bdoc\b/d' Makefile.in || die
}

src_configure() {
econf \
--localedir=/usr/share/locale \
$(use_enable nls) \
$(usex svg "" "--without-rsvg")
}

src_install() {
default
doicon -s scalable data/images/icons/${PN}.svg
make_desktop_entry ${PN} "TuxMath"
dodoc doc/{README,TODO,changelog}
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 34d30a2

Please sign in to comment.