Skip to content

Commit

Permalink
dev-python/more-itertools: revbump; add IUSE doc, test
Browse files Browse the repository at this point in the history
working test phase added as well as a doc build and install,
deps for each added accordingly, patches and testing done thx to
user 'drwx' via devs of the proxy-maintainers project

Package-Manager: portage-2.2.24
  • Loading branch information
Ian Delaney committed Dec 28, 2015
1 parent d5aac10 commit 34d71f5
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions dev-python/more-itertools/more-itertools-2.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="More routines for operating on iterables, beyond itertools"
HOMEPAGE="https://pypi.python.org/pypi/more-itertools"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
nosetests -w "${BUILD_DIR}" more_itertools --with-doctest \
|| die "tests fail with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit 34d71f5

Please sign in to comment.