Skip to content

Commit

Permalink
kde-misc/basket: Fix build against >=dev-libs/libgit2-0.99
Browse files Browse the repository at this point in the history
Thanks-to: Dan Goodliffe <[email protected]>
Closes: https://bugs.gentoo.org/710832
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 1, 2020
1 parent c96fc7e commit 34f8f2b
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 1 deletion.
5 changes: 4 additions & 1 deletion kde-misc/basket/basket-2.49b.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -57,7 +57,10 @@ DEPEND="${RDEPEND}
>=dev-qt/qtconcurrent-${QTMIN}:5
"

PATCHES=( "${FILESDIR}/${P}-xdg_mime_install_dir.patch" )
PATCHES=(
"${FILESDIR}/${P}-xdg_mime_install_dir.patch"
"${FILESDIR}/${P}-libgit2-0.99-compat.patch" # bug #710832
)

src_prepare() {
ecm_src_prepare
Expand Down
32 changes: 32 additions & 0 deletions kde-misc/basket/files/basket-2.49b-libgit2-0.99-compat.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 094580f207b5ba9f44e9af00834f9c93f06fb440 Mon Sep 17 00:00:00 2001
From: Dan Goodliffe <[email protected]>
Date: Thu, 27 Feb 2020 18:04:21 +0000
Subject: [PATCH] Use LIBGIT2_VER_MINOR for version test

Addresses compatibility with libgit2-0.99
---
src/application.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/application.cpp b/src/application.cpp
index c52fb574..81fcd121 100644
--- a/src/application.cpp
+++ b/src/application.cpp
@@ -56,7 +56,7 @@ Application::Application(int &argc, char **argv)


#ifdef WITH_LIBGIT2
- #if LIBGIT2_SOVERSION >= 22
+ #if LIBGIT2_VER_MINOR >= 22
git_libgit2_init();
#else
git_threads_init();
@@ -67,7 +67,7 @@ Application::Application(int &argc, char **argv)
Application::~Application()
{
#ifdef WITH_LIBGIT2
- #if LIBGIT2_SOVERSION >= 22
+ #if LIBGIT2_VER_MINOR >= 22
git_libgit2_shutdown();
#else
git_threads_shutdown();

0 comments on commit 34f8f2b

Please sign in to comment.