Skip to content

Commit

Permalink
x11-terms/qterminal: add version 1.4.0
Browse files Browse the repository at this point in the history
Signed-off-by: Jimi Huotari <[email protected]>
  • Loading branch information
Chiitoo committed Nov 9, 2023
1 parent be2a953 commit 350f938
Show file tree
Hide file tree
Showing 3 changed files with 55 additions and 3 deletions.
1 change: 1 addition & 0 deletions x11-terms/qterminal/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qterminal-1.3.0.tar.xz 217748 BLAKE2B 8da4e5388f13919cf67eb9931d4acd0e51b4b45a57acea1db1d8d98cfcec57e7b789e9b0f764fdefdfc71ff36b6a9722e2d389013b22872f8f730ebb1ff1d944 SHA512 f8cf2183da7af7869433b6057e20fba46be5cce30b75bdafb6cc0a5474e39fb1f2f8831f6841ca78f8b367f718ed2ee5a312a75850bc8192a37f20a6c5767a8d
DIST qterminal-1.4.0.tar.xz 219500 BLAKE2B 86ac46180a5f58b24a7bed40796af622fd4456e5b4bf58484cb1271a9bb41ae7688368e74245b36cab99a3309ab6132b3d0c188af460b3a7d543a9ad4a45eb1a SHA512 95c7fffa0a7a91dae338168748e1a9061eb7d393a083a70c59e3324f78ae8200e1e3bb07aa131564b208068e62fc744cc75e96694d70443559c7205ec9f91121
51 changes: 51 additions & 0 deletions x11-terms/qterminal/qterminal-1.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake xdg-utils

DESCRIPTION="Qt-based multitab terminal emulator"
HOMEPAGE="https://lxqt-project.org/"

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi

LICENSE="GPL-2 GPL-2+"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
DEPEND="
>=dev-qt/qtcore-5.15:5
>=dev-qt/qtdbus-5.15:5
>=dev-qt/qtgui-5.15:5
>=dev-qt/qtwidgets-5.15:5
>=dev-qt/qtx11extras-5.15:5
x11-libs/libX11
~x11-libs/qtermwidget-${PV}:=
test? ( dev-qt/qttest:5 )
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
)

cmake_src_configure
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}
6 changes: 3 additions & 3 deletions x11-terms/qterminal/qterminal-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -13,15 +13,15 @@ if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi

LICENSE="GPL-2 GPL-2+"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

BDEPEND=">=dev-util/lxqt-build-tools-0.12.0"
BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
DEPEND="
>=dev-qt/qtcore-5.15:5
>=dev-qt/qtdbus-5.15:5
Expand Down

0 comments on commit 350f938

Please sign in to comment.