Skip to content

Commit

Permalink
net-dns/unbound: bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
robbat2 committed Sep 27, 2017
1 parent b40400b commit 3524d17
Show file tree
Hide file tree
Showing 3 changed files with 132 additions and 1 deletion.
1 change: 1 addition & 0 deletions net-dns/unbound/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST unbound-1.5.1.tar.gz 4805176 SHA256 0ff82709fb2bd7ecbde8dbdcf60fa417d2b4337
DIST unbound-1.5.10.tar.gz 4941299 SHA256 a39b8b4fcca2a2b35a2daa53fe35150cc3f09038dc9acede09c912fc248a9486 SHA512 1c413886a12d4b626e03e076da6b9ccbcc8fd4769649fef8895eca74199bc22aec33c026e777524e8fe0327045a194f79b52282fe40674a9fb15cac58c4493f6 WHIRLPOOL 4e4ef7e4a89a6d8cd7b359a38cfb8a5cd99ea4e59a89ab894181b149346cf1e2875ec6b2af0985925cc50ff1c2f50fbfe569569ead2913127631781003c84742
DIST unbound-1.6.3.tar.gz 5381240 SHA256 4c7e655c1d0d2d133fdeb81bc1ab3aa5c155700f66c9f5fb53fa6a5c3ea9845f SHA512 1d84fcc4c4b2a2b5cce6540cf252ff964f4acae3b6567c61cee69b76c6cee3e00270b1f7cc7ad83a2754afb33cc199c8b6e8116e5b587811714398b1d34de8a3 WHIRLPOOL c4cc7b45686bb3e5128f8c2e28b6e87867b983e01c53d336d85f342dc84e5c9a01491a7325f8290620a02ff9323173f433892f114ee5f4350cf41e91bbc74831
DIST unbound-1.6.4.tar.gz 5477897 SHA256 df0a88816ec31ccb8284c9eb132e1166fbf6d9cde71fbc4b8cd08a91ee777fed SHA512 1abf50552c97b304884f07372f9fb05f9f30354647cf5299192deac81fa28a41d89d84ee092baef644a6069d0f545d36e7e814c9b8f83f21a7a53572d9a91907 WHIRLPOOL 36cadfa940ae121ab0d261fa70b91114462aeb56b0c3b1505e58a307248d4741a040b1cecd62ad42e95958798b7aa5331c45cc879d83298318d9eee184de8a17
DIST unbound-1.6.6.tar.gz 5460482 SHA256 972b14dc33093e672652a7b2b5f159bab2198b0fe9c9e1c5707e1895d4d4b390 SHA512 910fd0956b8828d3db0511a85bf6ab6c4c3982f17c70ccb7123d1de1650d24c2906bc29ac4ea83fd7d95d8af29e2cbc88df666f365e51296f552292ef9753016 WHIRLPOOL 0aff265050876defa900303c152f643258dd26b9c1fd4abdd901a849fe96481b488cafdd834dbca73b769dff19971300b5ae4798e3286c17bc5b24f70beb7a83
2 changes: 1 addition & 1 deletion net-dns/unbound/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,7 @@
<use>
<flag name="dnscrypt">Enable DNSCrypt support</flag>
<flag name="dnstap">Enable dnstap support</flag>
<flag name="ecdsa">Enable ECDSA support</flag>
<flag name="ecdsa">Enable ECDSA support</flag>
<flag name="gost">Enable GOST support</flag>
</use>
</pkgmetadata>
130 changes: 130 additions & 0 deletions net-dns/unbound/unbound-1.6.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,130 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
PYTHON_COMPAT=( python2_7 )

inherit eutils flag-o-matic multilib-minimal python-single-r1 systemd user

MY_P=${PN}-${PV/_/}
DESCRIPTION="A validating, recursive and caching DNS resolver"
HOMEPAGE="http://unbound.net/"
SRC_URI="http://unbound.net/downloads/${MY_P}.tar.gz"

LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
IUSE="debug dnscrypt dnstap +ecdsa gost libressl python selinux static-libs systemd test threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# Note: expat is needed by executable only but the Makefile is custom
# and doesn't make it possible to easily install the library without
# the executables. MULTILIB_USEDEP may be dropped once build system
# is fixed.

CDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/libevent-2.0.21:0=[${MULTILIB_USEDEP}]
libressl? ( >=dev-libs/libressl-2.2.4:0[${MULTILIB_USEDEP}] )
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
dnscrypt? ( dev-libs/libsodium )
dnstap? (
dev-libs/fstrm[${MULTILIB_USEDEP}]
>=dev-libs/protobuf-c-1.0.2-r1[${MULTILIB_USEDEP}]
)
ecdsa? (
!libressl? ( dev-libs/openssl:0[-bindist] )
)
python? ( ${PYTHON_DEPS} )"

DEPEND="${CDEPEND}
python? ( dev-lang/swig )
test? (
net-dns/ldns-utils[examples]
dev-util/splint
app-text/wdiff
)
systemd? ( sys-apps/systemd )
virtual/pkgconfig"

RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-bind )"

# bug #347415
RDEPEND="${RDEPEND}
net-dns/dnssec-root"

S=${WORKDIR}/${MY_P}

pkg_setup() {
enewgroup unbound
enewuser unbound -1 -1 /etc/unbound unbound

use python && python-single-r1_pkg_setup
}

src_prepare() {
# To avoid below error messages, set 'trust-anchor-file' to same value in
# 'auto-trust-anchor-file'.
# [23109:0] error: Could not open autotrust file for writing,
# /etc/dnssec/root-anchors.txt: Permission denied
epatch "${FILESDIR}"/${PN}-1.5.7-trust-anchor-file.patch

# required for the python part
multilib_copy_sources
}

src_configure() {
[[ ${CHOST} == *-darwin* ]] || append-ldflags -Wl,-z,noexecstack
multilib-minimal_src_configure
}

multilib_src_configure() {
econf \
$(use_enable debug) \
$(use_enable gost) \
$(use_enable dnscrypt) \
$(use_enable dnstap) \
$(use_enable ecdsa) \
$(use_enable static-libs static) \
$(use_enable systemd) \
$(multilib_native_use_with python pythonmodule) \
$(multilib_native_use_with python pyunbound) \
$(use_with threads pthreads) \
--disable-flto \
--disable-rpath \
--with-libevent="${EPREFIX}"/usr \
--with-pidfile="${EPREFIX}"/var/run/unbound.pid \
--with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
--with-ssl="${EPREFIX}"/usr \
--with-libexpat="${EPREFIX}"/usr

# http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
# $(use_enable debug lock-checks) \
# $(use_enable debug alloc-checks) \
# $(use_enable debug alloc-lite) \
# $(use_enable debug alloc-nonregional) \
}

multilib_src_install_all() {
prune_libtool_files --modules
use python && python_optimize

newinitd "${FILESDIR}"/unbound.initd unbound
newconfd "${FILESDIR}"/unbound.confd unbound

systemd_dounit "${FILESDIR}"/unbound.service
systemd_dounit "${FILESDIR}"/unbound.socket
systemd_newunit "${FILESDIR}"/unbound_at.service "[email protected]"
systemd_dounit "${FILESDIR}"/unbound-anchor.service

dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}

# bug #315519
dodoc contrib/unbound_munin_

docinto selinux
dodoc contrib/selinux/*

exeinto /usr/share/${PN}
doexe contrib/update-anchor.sh
}

0 comments on commit 3524d17

Please sign in to comment.