Skip to content

Commit

Permalink
dev-libs/uriparser: 0.9.3
Browse files Browse the repository at this point in the history
Ping: uriparser/uriparser#66
Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-2.3.64, Repoman-2.3.12
  • Loading branch information
hartwork committed Apr 28, 2019
1 parent be2dc86 commit 352dc85
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/uriparser/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST uriparser-0.9.1.tar.bz2 372722 BLAKE2B 6fe21d1f5a98564f3e08094b1e27a13ea00baff3c4e09645236d8b08cba5455d49862a2d66fec02057efbb3b3d2e36040aeab31630f516eedd1ef36c84211638 SHA512 c6a4f3b737d4c53ba14148a5be363d93947c8c32755b369726ccdd6e01e8a2293d2c94d448700fc97bb56092696b67965646ae07c9ef31be253e2279d0bc3821
DIST uriparser-0.9.3.tar.bz2 173073 BLAKE2B daf4d4ef2801850b8b4b3622ec195c7bfdc105cca085ea4a9d3ed9427bf7cf2eedcce4954b679a0ed1a79b7c57c98a1998b0cac27bd2b1de540aa79fdd4b160d SHA512 424419ea7b5f945b37ea06091d59e731c6a7ee76e7998f8a4e598036b3de8b593d62d1af6c6ddc7c31b43fc6795d4a5fa8d50da2508ca19de100a2222106fa3e
46 changes: 46 additions & 0 deletions dev-libs/uriparser/uriparser-0.9.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils

DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
HOMEPAGE="https://uriparser.github.io/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="doc qt5 test unicode"

RDEPEND=""
DEPEND="virtual/pkgconfig
doc? ( >=app-doc/doxygen-1.5.8
qt5? ( dev-qt/qthelp:5 ) )
test? ( >=dev-cpp/gtest-1.8.1 )"

REQUIRED_USE="test? ( unicode )"

DOCS=( AUTHORS ChangeLog THANKS )

src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DURIPARSER_BUILD_CHAR=ON
-DURIPARSER_BUILD_DOCS=$(usex doc ON OFF)
-DURIPARSER_BUILD_TESTS=$(usex test ON OFF)
-DURIPARSER_BUILD_TOOLS=ON
-DURIPARSER_BUILD_WCHAR_T=$(usex unicode ON OFF)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

if use doc && use qt5; then
dodoc "${BUILD_DIR}"/doc/*.qch
docompress -x /usr/share/doc/${PF}/${P}.qch
fi
}

0 comments on commit 352dc85

Please sign in to comment.