Skip to content

Commit

Permalink
media-libs/libepoxy: Version bump 1.5.2
Browse files Browse the repository at this point in the history
  • Loading branch information
mattst88 committed May 23, 2018
1 parent 5966b2c commit 35302c5
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libepoxy/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libepoxy-1.4.2.tar.gz 309973 BLAKE2B 029948aea64db917e782a57c901f537be796b269bcfdc9f4238db4fae41d3d11f68def2288d73a673b7e2a159e7ed2226761e4ebf603ec4f0fdcaf7f56eb02d1 SHA512 b94e1fe749c63a82f38369ff62b7d0d8cf1c55884159f030dc2919c17daf5811dd71cfd6a663edb38df66ff4ca53120a6a53501568cc8a582f08d4ae82fe9d89
DIST libepoxy-1.4.3.tar.gz 310823 BLAKE2B 6eab12a0ecf68a1bda3484c7cd71c0b3d62391e2bee8efd3c0fe7970ee4c3672f2dd81547d3884b301165accf3a8ce91a7c2a2e9686b1ca43c7f37cd15c5c946 SHA512 41c7a4eea66c89346b0ec71407b2d22bf645ed0ef81ebad560370903f138ed48abb6bc6bcc88c75a3a05497acc6720397db828d61301599c05040263a9f4f7f0
DIST libepoxy-1.5.1.tar.gz 324985 BLAKE2B 338b558ca3c174c04383dfc1bfe4f444965aef745b3043183d4024df62b37fdfc923c5c1d243a3061201a0f7b6946ce443d4ede3195b85d1022c187f46b08540 SHA512 f839f82e4ffabda42a2bb9c2822ba2e8da6583bdb481daa2e090e62b580fdfb0d11f96af790685769317ff2446d1d8d7cb6374b2049614ee938b84014b604bce
DIST libepoxy-1.5.2.tar.gz 324905 BLAKE2B bbc1904b99e6674b03259bc2a5f4076f248d698e80a6f57013f5c19dcb5d6c22fe8b821eae3ff014f40c273a6f91ad3efc054ec48ddf5b8e8b5d8e12da3b60cc SHA512 3dfa10b356d6105fc8b1fda62dcf025b20a786b37f82c8275b3f12df8d3a62bbd4a9800abac396cfb48b789f72ff3c5f7a796eb83f046e978f9403a53e6ddf0d
59 changes: 59 additions & 0 deletions media-libs/libepoxy/libepoxy-1.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGIT_REPO_URI="https://github.com/anholt/${PN}.git"

if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE='xml(+)'
inherit ${GIT_ECLASS} meson multilib-minimal python-any-r1

DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
HOMEPAGE="https://github.com/anholt/libepoxy"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi

LICENSE="MIT"
SLOT="0"
IUSE="test +X"

DEPEND="${PYTHON_DEPS}
media-libs/mesa[egl,${MULTILIB_USEDEP}]
X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
>=dev-util/meson-0.44.0"
RDEPEND=""

src_unpack() {
default
[[ $PV = 9999* ]] && git-r3_src_unpack
}

multilib_src_configure() {
local emesonargs=(
-Degl=yes
-Dglx=$(usex X)
-Dx11=$(usex X true false)
)
meson_src_configure
}

multilib_src_compile() {
meson_src_compile
}

multilib_src_test() {
meson_src_test
}

multilib_src_install() {
meson_src_install
}

0 comments on commit 35302c5

Please sign in to comment.