Skip to content

Commit

Permalink
dev-php/PEAR-Exception: Version bump for 1.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Mar 22, 2021
1 parent 9934e6c commit 353d2a1
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PEAR-Exception/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST PEAR_Exception-1.0.0.tgz 5270 BLAKE2B f6f6874083fcef2453e1d07e1ee3e900e4f7d18eca8e9a9eda9891492dd3fc1e31eb13944031e82044f976f1070463a3b099a8223d2dabb2da109bb123997f5a SHA512 f2078186fdad6c6ca59ac462a24f7f9689bea08d30f786acb7779d52cd433e490c752ba0a263067d869151b0c051cded327cb3477a039c5de68c854bff002b58
DIST PEAR_Exception-1.0.2.tgz 5458 BLAKE2B f6e7bc452729ec4419650a0fbd6ef091dd5ec1b91804e1b59c598e44d3c04bf043084e385daa56fd1f6c012090010490922627a465061fe57ef9d74a49960e91 SHA512 80022c03bb665307a9feea88312301c86c903c5b8737559f59fc0028a08976976dd21e19a7dc805c27ec41f90ebd310012cd56ba2c2c006cf0df7cea69323a91
29 changes: 29 additions & 0 deletions dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN="${PN/-/_}"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="The PEAR Exception base class"
HOMEPAGE="https://pear.php.net/package/PEAR_Exception"
SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-lang/php:*
!<=dev-php/PEAR-PEAR-1.10.3-r1"
DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
S="${WORKDIR}/${MY_P}"

src_install() {
insinto /usr/share/php
doins -r PEAR
}

src_test() {
phpunit --do-not-cache-result tests || die "test suite failed"
}

0 comments on commit 353d2a1

Please sign in to comment.