forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-text/aspell: Fix building with Unicode support
* EAPI=6 * Use dep on sys-libs/ncurses using newly introduced IUSE="unicode" * Made PATCHES -p1 compliant * Fixed unicode handling by pulling in ncurses/ncursesw using PKG_CHECK_MODULES instead of automagic discovery in configure.ac * Add missing '|| die' statements Closes: gentoo#2269 Signed-off-by: David Seifert <[email protected]>
- Loading branch information
1 parent
6ebab4f
commit 354f36b
Showing
5 changed files
with
376 additions
and
10 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,90 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit autotools flag-o-matic libtool toolchain-funcs | ||
|
||
DESCRIPTION="A spell checker replacement for ispell" | ||
HOMEPAGE="http://aspell.net/" | ||
SRC_URI="mirror://gnu/aspell/${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris" | ||
IUSE="nls unicode" | ||
|
||
PDEPEND="app-dicts/aspell-en" | ||
LANGS="af be bg br ca cs cy da de de-1901 el en eo es et fi fo fr ga gl he hr | ||
hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi" | ||
for lang in ${LANGS}; do | ||
IUSE+=" l10n_${lang}" | ||
# Need to keep linguas_* for now, since aspell uses gettext | ||
IUSE+=" linguas_${lang/-/_}" | ||
case ${lang} in | ||
de-1901) dict="de-alt" ;; | ||
pt-BR) dict="pt-br" ;; | ||
*) dict="${lang}" ;; | ||
esac | ||
PDEPEND+=" l10n_${lang}? ( app-dicts/aspell-${dict} )" | ||
done | ||
unset dict lang LANGS | ||
|
||
# English dictionary 0.5 is incompatible with aspell-0.6 | ||
RDEPEND=" | ||
sys-libs/ncurses:0=[unicode?] | ||
nls? ( virtual/libintl ) | ||
!=app-dicts/aspell-en-0.5* | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
nls? ( sys-devel/gettext ) | ||
" | ||
|
||
HTML_DOCS=( manual/aspell{,-dev}.html ) | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-0.60.5-nls.patch" | ||
"${FILESDIR}/${PN}-0.60.5-solaris.patch" | ||
"${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch" | ||
"${FILESDIR}/${PN}-0.60.6.1-clang.patch" | ||
# includes fix for bug #467602 | ||
"${FILESDIR}/${PN}-0.60.6.1-unicode.patch" | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
rm m4/lt* m4/libtool.m4 || die | ||
eautoreconf | ||
elibtoolize --reverse-deps | ||
|
||
# Parallel install of libtool libraries doesn't always work. | ||
# https://lists.gnu.org/archive/html/libtool/2011-03/msg00003.html | ||
# This has to be after automake has run so that we don't clobber | ||
# the default target that automake creates for us. | ||
echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in || die | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
$(use_enable nls) \ | ||
$(use_enable unicode) \ | ||
--disable-static \ | ||
--sysconfdir="${EPREFIX}"/etc/aspell | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
docinto examples | ||
dodoc "${S}"/examples/*.c | ||
|
||
# install ispell/aspell compatibility scripts | ||
newbin scripts/ispell ispell-aspell | ||
newbin scripts/spell spell-aspell | ||
|
||
# we explicitly pass '--disable-static' to econf, | ||
# hence we can delete .la files unconditionally | ||
find "${D}" -name '*.la' -delete || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,8 @@ | ||
* [email protected]: on Solaris 10 _XOPEN_SOURCE_EXTENDED may not be | ||
defined when including wchar.h with g++ | ||
|
||
--- prog/check_funs.cpp | ||
+++ prog/check_funs.cpp | ||
--- a/prog/check_funs.cpp | ||
+++ b/prog/check_funs.cpp | ||
@@ -18,10 +18,6 @@ | ||
|
||
#include "settings.h" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.