Skip to content

Commit

Permalink
app-text/aspell: Fix building with Unicode support
Browse files Browse the repository at this point in the history
* EAPI=6
* Use dep on sys-libs/ncurses using newly introduced IUSE="unicode"
* Made PATCHES -p1 compliant
* Fixed unicode handling by pulling in ncurses/ncursesw
  using PKG_CHECK_MODULES instead of automagic discovery
  in configure.ac
* Add missing '|| die' statements

Closes: gentoo#2269

Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
kempniu authored and SoapGentoo committed Sep 9, 2016
1 parent 6ebab4f commit 354f36b
Show file tree
Hide file tree
Showing 5 changed files with 376 additions and 10 deletions.
90 changes: 90 additions & 0 deletions app-text/aspell/aspell-0.60.6.1-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools flag-o-matic libtool toolchain-funcs

DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="mirror://gnu/aspell/${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="nls unicode"

PDEPEND="app-dicts/aspell-en"
LANGS="af be bg br ca cs cy da de de-1901 el en eo es et fi fo fr ga gl he hr
hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi"
for lang in ${LANGS}; do
IUSE+=" l10n_${lang}"
# Need to keep linguas_* for now, since aspell uses gettext
IUSE+=" linguas_${lang/-/_}"
case ${lang} in
de-1901) dict="de-alt" ;;
pt-BR) dict="pt-br" ;;
*) dict="${lang}" ;;
esac
PDEPEND+=" l10n_${lang}? ( app-dicts/aspell-${dict} )"
done
unset dict lang LANGS

# English dictionary 0.5 is incompatible with aspell-0.6
RDEPEND="
sys-libs/ncurses:0=[unicode?]
nls? ( virtual/libintl )
!=app-dicts/aspell-en-0.5*
"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )
"

HTML_DOCS=( manual/aspell{,-dev}.html )
PATCHES=(
"${FILESDIR}/${PN}-0.60.5-nls.patch"
"${FILESDIR}/${PN}-0.60.5-solaris.patch"
"${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
"${FILESDIR}/${PN}-0.60.6.1-clang.patch"
# includes fix for bug #467602
"${FILESDIR}/${PN}-0.60.6.1-unicode.patch"
)

src_prepare() {
default

rm m4/lt* m4/libtool.m4 || die
eautoreconf
elibtoolize --reverse-deps

# Parallel install of libtool libraries doesn't always work.
# https://lists.gnu.org/archive/html/libtool/2011-03/msg00003.html
# This has to be after automake has run so that we don't clobber
# the default target that automake creates for us.
echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in || die
}

src_configure() {
econf \
$(use_enable nls) \
$(use_enable unicode) \
--disable-static \
--sysconfdir="${EPREFIX}"/etc/aspell
}

src_install() {
default

docinto examples
dodoc "${S}"/examples/*.c

# install ispell/aspell compatibility scripts
newbin scripts/ispell ispell-aspell
newbin scripts/spell spell-aspell

# we explicitly pass '--disable-static' to econf,
# hence we can delete .la files unconditionally
find "${D}" -name '*.la' -delete || die
}
4 changes: 2 additions & 2 deletions app-text/aspell/files/aspell-0.60.5-solaris.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
* [email protected]: on Solaris 10 _XOPEN_SOURCE_EXTENDED may not be
defined when including wchar.h with g++

--- prog/check_funs.cpp
+++ prog/check_funs.cpp
--- a/prog/check_funs.cpp
+++ b/prog/check_funs.cpp
@@ -18,10 +18,6 @@

#include "settings.h"
Expand Down
4 changes: 2 additions & 2 deletions app-text/aspell/files/aspell-0.60.6-darwin-bundles.patch
Original file line number Diff line number Diff line change
Expand Up @@ -5,8 +5,8 @@ Apple suggests using .bundle. libtool on Gentoo generates .bundle files
for modules on Darwin, so we need aspell to actually look for .bundle,
not .so.

--- lib/new_filter.cpp
+++ lib/new_filter.cpp
--- a/lib/new_filter.cpp
+++ b/lib/new_filter.cpp
@@ -458,11 +458,23 @@
module->file.assign(option_file.str(), slash + 1 - option_file.str());
//module->file += "lib";
Expand Down
12 changes: 6 additions & 6 deletions app-text/aspell/files/aspell-0.60.6.1-clang.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
From https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=180565
--- interfaces/cc/aspell.h.orig 2011-07-02 17:53:27.000000000 -0400
+++ interfaces/cc/aspell.h 2015-07-29 11:23:32.000000000 -0400
--- a/interfaces/cc/aspell.h
+++ b/interfaces/cc/aspell.h
@@ -237,6 +237,7 @@
/******************************** errors ********************************/

Expand All @@ -17,8 +17,8 @@ From https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=180565


/******************************* speller *******************************/
--- prog/aspell.cpp.orig 2011-07-04 05:13:58.000000000 -0400
+++ prog/aspell.cpp 2015-07-29 11:22:57.000000000 -0400
--- a/prog/aspell.cpp
+++ b/prog/aspell.cpp
@@ -25,6 +25,7 @@
# include <langinfo.h>
#endif
Expand All @@ -35,8 +35,8 @@ From https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=180565
#include "file_util.hpp"
#include "fstream.hpp"
#include "info.hpp"
--- prog/checker_string.hpp.orig 2011-07-02 17:09:09.000000000 -0400
+++ prog/checker_string.hpp 2015-07-29 11:24:50.000000000 -0400
--- a/prog/checker_string.hpp
+++ b/prog/checker_string.hpp
@@ -6,6 +6,7 @@

#include <stdio.h>
Expand Down
Loading

0 comments on commit 354f36b

Please sign in to comment.