Skip to content

Commit

Permalink
lxqt-base/lxqt-config: add version 0.15.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <[email protected]>
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
Chiitoo authored and a17r committed May 20, 2020
1 parent 623cc8e commit 356e16f
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions lxqt-base/lxqt-config/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lxqt-config-0.14.1.tar.xz 293304 BLAKE2B f090d7878815edc4f3f0078301a099ffc8ff57865516a9097db75faa1627af33c60d76b75cef8a7da5e9e790869e6768f54c3b17c59b038578f22d645c3c22fd SHA512 747644f8e0623cb2e8eadda57c7307387423152a089d5b423b06650fbf235371764a26e82363cbee9db5c1145e3fdb754e6ecdcf0930dccec375dda424c8b13f
DIST lxqt-config-0.15.0.tar.xz 312468 BLAKE2B 2b3eb43141f3b46996b785b7cd19b709028c8cecc455a63578c93a9ae580148bc35df1192591bf0fdb5584d2cf66f589dbdde0d43c6848dda263d1f0b80e8c59 SHA512 68dc8ecc38033a7a93167fb0afbe45b3e14eb1132c3faf3395ebed1fc96b5836e8db003ecffde0417dfaf9e73b70fcc69a06523319f1f858cd2020eb61113a0d
74 changes: 74 additions & 0 deletions lxqt-base/lxqt-config/lxqt-config-0.15.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake xdg-utils

DESCRIPTION="LXQt system configuration control center"
HOMEPAGE="https://lxqt.github.io/"

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi

LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
SLOT="0"
IUSE="+monitor +touchpad"

BDEPEND="
dev-qt/linguist-tools:5
>=dev-util/lxqt-build-tools-0.7.0
"
DEPEND="
>=dev-libs/libqtxdg-3.3.1
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
kde-frameworks/kwindowsystem:5
=lxqt-base/liblxqt-$(ver_cut 1-2)*
sys-libs/zlib:=
x11-apps/setxkbmap
x11-libs/libxcb:=
x11-libs/libX11
x11-libs/libXcursor
x11-libs/libXfixes
monitor? ( kde-plasma/libkscreen:5= )
touchpad? (
virtual/libudev
x11-drivers/xf86-input-libinput
x11-libs/libXext
x11-libs/libXi
)
"
RDEPEND="${DEPEND}
!lxqt-base/lxqt-l10n
"

src_configure() {
local mycmakeargs=(
-DWITH_MONITOR=$(usex monitor)
-DWITH_TOUCHPAD=$(usex touchpad)
)
cmake_src_configure
}

src_install() {
cmake_src_install
doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit 356e16f

Please sign in to comment.