Skip to content

Commit

Permalink
games-strategy/hedgewars: Fix build with CMake 3.24
Browse files Browse the repository at this point in the history
...caused by the package copying internal CMake modules...

Closes: https://bugs.gentoo.org/870010
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Sep 13, 2022
1 parent 0016123 commit 35a25be
Show file tree
Hide file tree
Showing 2 changed files with 125 additions and 1 deletion.
122 changes: 122 additions & 0 deletions games-strategy/hedgewars/files/hedgewars-1.0.0-cmake-3.24.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,122 @@
Description: Cherry-pick change 42f7e397894c5132b4706f478e62ce5d648119c1 into our custom embedded version
Author: Gianfranco Costamagna <[email protected]>
Forwarded: irc
Last-Update: 2022-08-05

--- hedgewars-1.0.0.orig/cmake_modules/CMakeSystemSpecificInformation.cmake
+++ hedgewars-1.0.0/cmake_modules/CMakeSystemSpecificInformation.cmake
@@ -1,70 +1,6 @@
-# XXX Emscripten:
-# This file is copied as-is from the CMake source tree. Due to how CMake
-# platform toolchain files work, we must have a copy of this file located
-# relative to Emscripten platform toolchain file, or file inclusion order
-# in cmGlobalGenerator::EnableLanguage will not find Emscripten.cmake
-# toolchain file, and as a result, it is not possible to set the default
-# compilation output suffix to .js, and as a consequence the script
-# check_function_exists() will not function properly (it will try to
-# build to wrong file suffix)
-
-# CMake - Cross Platform Makefile Generator
-# Copyright 2000-2014 Kitware, Inc.
-# Copyright 2000-2011 Insight Software Consortium
-# All rights reserved.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-
-# * Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# * Neither the names of Kitware, Inc., the Insight Software Consortium,
-# nor the names of their contributors may be used to endorse or promote
-# products derived from this software without specific prior written
-# permission.
-
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# ------------------------------------------------------------------------------
-
-# The above copyright and license notice applies to distributions of
-# CMake in source and binary form. Some source files contain additional
-# notices of original copyright by their contributors; see each source
-# for details. Third-party software packages supplied with CMake under
-# compatible licenses provide their own copyright notices documented in
-# corresponding subdirectories.
-
-# ------------------------------------------------------------------------------
-
-# CMake was initially developed by Kitware with the following sponsorship:
-
-# * National Library of Medicine at the National Institutes of Health
-# as part of the Insight Segmentation and Registration Toolkit (ITK).
-
-# * US National Labs (Los Alamos, Livermore, Sandia) ASC Parallel
-# Visualization Initiative.
-
-# * National Alliance for Medical Image Computing (NAMIC) is funded by the
-# National Institutes of Health through the NIH Roadmap for Medical Research,
-# Grant U54 EB005149.
+# Distributed under the OSI-approved BSD 3-Clause License. See accompanying
+# file Copyright.txt or https://cmake.org/licensing for details.

-# * Kitware, Inc.

# This file is included by cmGlobalGenerator::EnableLanguage.
# It is included after the compiler has been determined, so
@@ -78,8 +14,19 @@
set(APPLE )
set(UNIX )
set(CYGWIN )
+set(MSYS )
set(WIN32 )

+function(_cmake_record_install_prefix )
+ set(_CMAKE_SYSTEM_PREFIX_PATH_INSTALL_PREFIX_VALUE "${CMAKE_INSTALL_PREFIX}" PARENT_SCOPE)
+ set(count 0)
+ foreach(value IN LISTS CMAKE_SYSTEM_PREFIX_PATH)
+ if(value STREQUAL CMAKE_INSTALL_PREFIX)
+ math(EXPR count "${count}+1")
+ endif()
+ endforeach()
+ set(_CMAKE_SYSTEM_PREFIX_PATH_INSTALL_PREFIX_COUNT "${count}" PARENT_SCOPE)
+endfunction()

# include Generic system information
include(CMakeGenericSystem)
@@ -91,17 +38,16 @@ include(${CMAKE_SYSTEM_INFO_FILE} OPTION

if(NOT _INCLUDED_SYSTEM_INFO_FILE)
message("System is unknown to cmake, create:\n${CMAKE_SYSTEM_INFO_FILE}"
- " to use this system, please send your config file to "
- "[email protected] so it can be added to cmake")
+ " to use this system, please post your config file on "
+ "discourse.cmake.org so it can be added to cmake")
if(EXISTS ${CMAKE_BINARY_DIR}/CMakeCache.txt)
configure_file(${CMAKE_BINARY_DIR}/CMakeCache.txt
${CMAKE_BINARY_DIR}/CopyOfCMakeCache.txt COPYONLY)
message("Your CMakeCache.txt file was copied to CopyOfCMakeCache.txt. "
- "Please send that file to [email protected].")
- endif()
+ "Please post that file on discourse.cmake.org.")
+ endif()
endif()

-
# optionally include a file which can do extra-generator specific things, e.g.
# CMakeFindEclipseCDT4.cmake asks gcc for the system include dirs for the Eclipse CDT4 generator
if(CMAKE_EXTRA_GENERATOR)
4 changes: 3 additions & 1 deletion games-strategy/hedgewars/hedgewars-1.0.0-r100.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -56,6 +56,8 @@ PATCHES=(
"${FILESDIR}/${PN}-1.0.0-cmake_lua_version.patch"
# http://hg.hedgewars.org/hedgewars/rev/6832dab555ae
"${FILESDIR}/${PN}-1.0.0-fpc-3.2.patch"
# Patch by Debian
"${FILESDIR}/${P}-cmake-3.24.patch" # bug 870010
)

S="${WORKDIR}"/${MY_P}
Expand Down

0 comments on commit 35a25be

Please sign in to comment.