Skip to content

Commit

Permalink
net-misc/youtube-dl: Bump to 2020.11.24
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 23, 2020
1 parent 04bf8cf commit 35a6dab
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST youtube-dl-2020.11.12.tar.gz 3188015 BLAKE2B 17267ce8c3068f3a1aca20b23a77a9
DIST youtube-dl-2020.11.18.tar.gz 3186065 BLAKE2B 1c27ffc59bbf7793c58e554923ea7ef8a528191e896f64e39ecb181582bcd9bfecf6de5622e70c873528b1b0b3a8335a12ab6a7b3ac71d603391ebbf83110b89 SHA512 110de857759b4c4bd0160242adebb3d8690bda2203a28a7b1a2ac1cdd9bca058702fd0b323010629e74bbb2df38f50c67b710bc2a6ad4cc907827ee013d0dbcf
DIST youtube-dl-2020.11.19.tar.gz 3188309 BLAKE2B 775700f26491257125eb68ce49c1ec062ae21568cb3f20463330430d225e2af4e02daed839e5c29cded9b92921a16f0a9611fedc748ca1cd6152c33a131d1503 SHA512 042b0fbe0f1100c338924c9278d4071aaf4cd27dfc7c9d951244aec91a9168358e7463352548a5b7c6a567b077a9db69776790c3a35e08bdf6552f465b4f735f
DIST youtube-dl-2020.11.21.1.tar.gz 3193010 BLAKE2B a7c04f83815e5b7b6b75109863cf470ca2f756523c08fdfb65386756c9cbfea80e9ee2583f26cb41aa382f747b125543b86bf521a7c0973632a3ca331f48499c SHA512 8f9b77eabe7821f952b706fff4db7ef4e0627dc8333fdfb5cfd0d1dfe4f3bab9ca54525c8c9ed7c285d75fe08c02060dd05744a9a82a526789c67040f8cbcd09
DIST youtube-dl-2020.11.24.tar.gz 3207954 BLAKE2B 9c1382b73018fc366b4dfbc077be4bdc673812b7073c4e2e79159ccdf5d05443f0b07def13187f1a01e6ed36fc57a29c69d6c1a11c3670bbad3774e8f7f54f4f SHA512 51e29b00fe69a53b957b2108940d9fbe374aadf835e4449b15e799be59858f5273934fccf930701c2eb1c867c65b3b921a55f98b83088f9f0e01541f6fa7a90c
72 changes: 72 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2020.11.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=(python3_{6..9})

DISTUTILS_USE_SETUPTOOLS=rdepend

inherit bash-completion-r1 distutils-r1 readme.gentoo-r1

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
S=${WORKDIR}/${PN}

LICENSE="public-domain"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
SLOT="0"

RDEPEND="
dev-python/pycryptodome[${PYTHON_USEDEP}]
"

distutils_enable_tests nose

src_prepare() {
sed -i -e '/flake8/d' Makefile || die
distutils-r1_src_prepare
}

python_test() {
emake offlinetest
}

python_install_all() {
dodoc README.txt
doman ${PN}.1

newbashcomp ${PN}.bash-completion ${PN}

insinto /usr/share/zsh/site-functions
newins ${PN}.zsh _${PN}

insinto /usr/share/fish/vendor_completions.d
doins ${PN}.fish

distutils-r1_python_install_all

rm -r "${ED}"/usr/etc || die
rm -r "${ED}"/usr/share/doc/youtube_dl || die
}

pkg_postinst() {
elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
elog
elog "${PN} works fine on its own on most sites. However, if you want"
elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
elog "On some sites - most notably YouTube - videos can be retrieved in"
elog "a higher quality format without sound. ${PN} will detect whether"
elog "ffmpeg is present and automatically pick the best option."
elog
elog "Videos or video formats streamed via RTMP protocol can only be"
elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
elog
elog "Downloading MMS and RTSP videos requires either mplayer"
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
elog
elog "If you want ${PN} to embed thumbnails from the metadata into the"
elog "resulting MP4 files, consider installing media-video/atomicparsley"
}

0 comments on commit 35a6dab

Please sign in to comment.