forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/libinput: Version bump to 1.7.0
- Loading branch information
Showing
2 changed files
with
56 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f070f8863393d6fb7ca4c68e451 SHA512 ecd1ddc737b8207d9e494f809340e2c0ac2927db80cf4c325ba12fb84387138d0128df7e841c87feafe425d6382f87f123f28531f7045fbcdd1176559895b79b WHIRLPOOL 99f18e00e2a4a284b7995f677053501989b526e16f41e508023638a1c0e660940d0cb991f399480a30a49073063aab1651e52bdea7861266300d9db885806ac4 | ||
DIST libinput-1.6.2.tar.xz 929180 SHA256 96fc0e0b24a96042b16e561201979dfa4a3f00a642538195c62f72b79f4084fa SHA512 f1e1436ec4259ebddf93a50fe4d39a52713efd246a39a072b44bf296a413bdadbb789d6a4f0107ed3eb37afe34a37a43c9e75dcf814462385011eff2d3f42db7 WHIRLPOOL e9ed43ab8efb5b984a8c431e82880a691f7c94577a7a3789cf1e52c82f8aeee70d56474895a349f286f4d7fc845be8302ca7432b8e4801a6233fbe96b0078db3 | ||
DIST libinput-1.6.3.tar.xz 926740 SHA256 74da2798728e79c3aedfffa268d8fe811c3766ca3708309c0dc45502be137da1 SHA512 be1ab191b5605943d6f46a5fee7af9ecba83ab30ba3d38b6ec136980f2183f6dcb5aaf048aa81a096c4f51b6de05bebc83b4ffa29a0574752062a994f377aa5f WHIRLPOOL e90739d84b87c9a419bbbb636cb535bebd51cacc18d215f87f952af41bb67a747de0c4c732cd83bd4d23143b3d6d4090a09e150d41f05edfb260e26a08688778 | ||
DIST libinput-1.7.0.tar.xz 924472 SHA256 12a670f63d01e9e9c98ad0b31aef22160aac52187b4ee8f068a6902181c1a8a8 SHA512 9058eab813ea3de230835155ca843f248127cbafaf1aecc9a2e209a0215b090beef0468cc863a24320f8d0db1f2863baba680e2416e9e409e958b2c1d18e43a1 WHIRLPOOL e2f2d90bf7c16b0b1d1694d5e8ec998de73b335e4aa57b833fdf77ebbb9e559fac7a10929a3495f40b9312f15178954ea450670d067d46af61a75be06643ccc0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit udev | ||
|
||
DESCRIPTION="Library to handle input devices in Wayland" | ||
HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/" | ||
SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0/10" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="input_devices_wacom test" | ||
# Tests require write access to udev rules directory which is a no-no for live system. | ||
# Other tests are just about logs, exported symbols and autotest of the test library. | ||
RESTRICT="test" | ||
|
||
RDEPEND=" | ||
input_devices_wacom? ( >=dev-libs/libwacom-0.20 ) | ||
>=dev-libs/libevdev-0.4 | ||
>=sys-libs/mtdev-1.1 | ||
virtual/libudev | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
# test? ( | ||
# >=dev-libs/check-0.9.10 | ||
# dev-util/valgrind | ||
# sys-libs/libunwind ) | ||
|
||
src_prepare() { | ||
default | ||
# Doc handling in kinda strange but everything | ||
# is available in the tarball already. | ||
sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \ | ||
-i Makefile.am Makefile.in || die | ||
} | ||
|
||
src_configure() { | ||
# gui can be built but will not be installed | ||
# building documentation silently fails with graphviz syntax errors | ||
econf \ | ||
--disable-documentation \ | ||
--disable-event-gui \ | ||
$(use_enable input_devices_wacom libwacom) \ | ||
$(use_enable test tests) \ | ||
--with-udev-dir="$(get_udevdir)" | ||
} | ||
|
||
src_install() { | ||
emake install DESTDIR="${D}" | ||
dodoc -r doc/html | ||
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die | ||
} |