Skip to content

Commit

Permalink
games-arcade/cdogs-sdl: add 1.2.0
Browse files Browse the repository at this point in the history
This version comes with pre-generated msg.pb.c removing
the need for protobuf-python.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Dec 2, 2021
1 parent f2587e6 commit 362339d
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-arcade/cdogs-sdl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cdogs-sdl-1.1.1.tar.gz 35073687 BLAKE2B e4bcdbcafd281cfe127fc8b90bda479055042bf541ea7be7eaf2d0959e6d596565c8fca16bc703ca8263281d18372d89fa8ffa787592f3c01c0b048504df10fa SHA512 2d1357ba4a9892a7309d60b98aacf242b6d2b76f07f9f0a13fe0d97713b97507d1f163dfc63c1ac73c06b52590cda93bc212731bf201d5221ade8fa8b2e64598
DIST cdogs-sdl-1.2.0.tar.gz 35018104 BLAKE2B 1a87f0c6e4af0fda69c0dd98249b319b58411a5b0b7377c21ebef51939f2b6e76959a00bf7fd5602b07bebb9eaab22c840699ae1c54e5d4dcb1aa26852fb8ba0 SHA512 70a5a4bb8e48cf53a4497807b14d8a70e26ad6b74f0c4675b3d98667c867d499d372f323e7abb669ebef08b1d6b5ac9c840ab14eada38e7b868d3099ed6b3e35
46 changes: 46 additions & 0 deletions games-arcade/cdogs-sdl/cdogs-sdl-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake xdg

DESCRIPTION="Classic overhead run-and-gun game"
HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
SRC_URI="https://github.com/cxong/cdogs-sdl/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+ BSD-2 CC0-1.0 CC-BY-3.0 CC-BY-SA-3.0 XMAME"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
media-libs/libsdl2[haptic,opengl]
media-libs/sdl2-image[png]
media-libs/sdl2-mixer[vorbis,wav]
net-libs/enet:1.3="
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-1.1.1-cmake.patch
)

CMAKE_IN_SOURCE_BUILD=1 # msg.pb.c not found

src_configure() {
local mycmakeargs=(
-DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/
-DBUILD_EDITOR=OFF
-DUSE_SHARED_ENET=ON
)

cmake_src_configure
}

src_install() {
cmake_src_install

dodoc doc/{AUTHORS,original_readme.txt}

# CREDITS is used at runtime, rest is licenses or duplicates
find "${ED}"/usr/share/${PN}/doc -type f ! -name CREDITS -delete || die
}

0 comments on commit 362339d

Please sign in to comment.