Skip to content

Commit

Permalink
app-text/enchant: Fixed compilation with hunspell-1.4 (bug #583486).
Browse files Browse the repository at this point in the history
Bumped to EAPI-6.

Package-Manager: portage-2.3.0
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jul 27, 2016
1 parent faac97b commit 362ac17
Show file tree
Hide file tree
Showing 2 changed files with 23 additions and 2 deletions.
9 changes: 7 additions & 2 deletions app-text/enchant/enchant-1.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=4
EAPI=6

inherit eutils autotools

Expand Down Expand Up @@ -30,7 +30,12 @@ REQUIRED_USE="|| ( hunspell aspell zemberek )"

DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"

PATCHES=(
"${FILESDIR}/${P}-hunspell140_fix.patch"
)

src_prepare() {
default
sed -i \
-e 's:noinst_PROGRAMS:check_PROGRAMS:' \
tests/Makefile.am || die
Expand Down
16 changes: 16 additions & 0 deletions app-text/enchant/files/enchant-1.6.0-hunspell140_fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
https://bugs.gentoo.org/583486
http://bugzilla.abisource.com/show_bug.cgi?id=13772

--- enchant-1.6.0/src/myspell/myspell_checker.cpp
+++ enchant-1.6.0/src/myspell/myspell_checker.cpp
@@ -148,6 +148,10 @@
g_iconv_close(m_translate_out);
}

+#ifndef MAXWORDLEN
+# define MAXWORDLEN 100
+#endif
+
bool
MySpellChecker::checkWord(const char *utf8Word, size_t len)
{

0 comments on commit 362ac17

Please sign in to comment.