forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/gvim: version bump to v9.0.0828.
This is needed to resolve CVE-2022-3705. Bug: https://bugs.gentoo.org/879257 Signed-off-by: Vaibhav Rustagi <[email protected]> Closes: gentoo#28119 Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
83d6d09
commit 3646247
Showing
2 changed files
with
366 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST vim-9.0.0099.tar.gz 16712565 BLAKE2B b3277ebda0bb40601d995935422006d1a266bb862be612e69abd057a7342d13457ded5cb4743cf43a09b7d2001438f5a426ba12c30947bb7c193188c5fc13cf7 SHA512 ca0dea7b7fd78cf9c7cd4656611d066540f9d81ab17bcb75c79f0e989bdcfb769940ea29f75445c554b159e9eb3b2c4f9d77448254c3e4e4457b1bf721936498 | ||
DIST vim-9.0.0399.tar.gz 16833387 BLAKE2B f9d6588920b49ef32b82d012e1c4f8a34dc505267b67027a3b4302dd99d7987645c29a91fdb234fffa873b342488b4d9c85d05d3fe7a332042781881a61bea5e SHA512 6b261bf3aaa355e7a42de1785b134bccc51086495578730b9bc3b8e048679caa3a901e576a360cba5f1aa4d164c7f162a3f916e945b3f5f71e893ea30e0ca826 | ||
DIST vim-9.0.0655.tar.gz 16804127 BLAKE2B e021ff4dd370cdd9b39fb9df0a12309215abd780ec297760b92b6caf924882465b28f9ba65d94ad75a229eb01c8f393f24a29a11919a96d78bb6fb45ef2971e3 SHA512 aa267941e835eecbeeffa7989fb525bdf4269f84d9c88d135a26d74ab7d025487863405b6e0f1391023c30193a122ed3e85a7a71bd4dc48058f3fe3377798f38 | ||
DIST vim-9.0.0828.tar.gz 16782339 BLAKE2B 6b997c1c828338d64a8b204a1e232676ec075834b1b7e74c2fc671e315f9bf6026b0c419ebb3c31e7ce58dbca23828ca11d866b2bfcb73f8a86fb31fa0d51b00 SHA512 03f93515039a2f275a8fe6b84bbac5875ffff17768ab3201e111eba4897a2485fe4ccfe238151f393334c7a6ea77eddd8898f0b816e26dbdb884f4e6bcbd2943 | ||
DIST vim-patches-vim-9.0.0049-patches.tar.gz 2743 BLAKE2B dff3e215b235e1cbc2c62b1af2d1414d10b794dbee9f5e7797fb3d34e00c2e065c339d4c82bf28aed53e0b5f2f8f1ee5c7ce69851cd63360788609bf144ac922 SHA512 7d5c64d674fa77048fdca7287072c0e488723133e254c10711dbadf750416c368725327ca9b76f332017bc70aa544a9baef671765eabf0d172d39921ffd7d942 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,365 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
# Please bump with app-editors/vim-core and app-editors/vim | ||
|
||
VIM_VERSION="9.0" | ||
LUA_COMPAT=( lua5-{1..4} luajit ) | ||
PYTHON_COMPAT=( python3_{8..11} ) | ||
PYTHON_REQ_USE="threads(+)" | ||
USE_RUBY="ruby27 ruby30 ruby31" | ||
|
||
inherit bash-completion-r1 flag-o-matic lua-single prefix python-single-r1 ruby-single toolchain-funcs vim-doc xdg-utils | ||
|
||
if [[ ${PV} == 9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/vim/vim.git" | ||
EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV} | ||
else | ||
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz | ||
https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-9.0.0049-patches.tar.gz" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris" | ||
fi | ||
S="${WORKDIR}"/vim-${PV} | ||
|
||
DESCRIPTION="GUI version of the Vim text editor" | ||
HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim" | ||
|
||
LICENSE="vim" | ||
SLOT="0" | ||
IUSE="acl aqua crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl" | ||
REQUIRED_USE=" | ||
lua? ( ${LUA_REQUIRED_USE} ) | ||
python? ( ${PYTHON_REQUIRED_USE} ) | ||
aqua? ( !motif ) | ||
" | ||
|
||
RDEPEND=" | ||
~app-editors/vim-core-${PV} | ||
>=app-eselect/eselect-vi-1.1 | ||
>=sys-libs/ncurses-5.2-r2:0= | ||
x11-libs/libICE | ||
x11-libs/libSM | ||
x11-libs/libXext | ||
x11-libs/libXt | ||
acl? ( kernel_linux? ( sys-apps/acl ) ) | ||
!aqua? ( | ||
motif? ( >=x11-libs/motif-2.3:0 ) | ||
!motif? ( | ||
x11-libs/gtk+:3 | ||
x11-libs/libXft | ||
) | ||
) | ||
crypt? ( dev-libs/libsodium:= ) | ||
cscope? ( dev-util/cscope ) | ||
lua? ( | ||
${LUA_DEPS} | ||
$(lua_gen_impl_dep 'deprecated' lua5-1) | ||
) | ||
nls? ( virtual/libintl ) | ||
perl? ( dev-lang/perl:= ) | ||
python? ( ${PYTHON_DEPS} ) | ||
racket? ( dev-scheme/racket ) | ||
ruby? ( ${RUBY_DEPS} ) | ||
selinux? ( sys-libs/libselinux ) | ||
session? ( x11-libs/libSM ) | ||
sound? ( media-libs/libcanberra ) | ||
tcl? ( dev-lang/tcl:0= ) | ||
" | ||
DEPEND="${RDEPEND}" | ||
# configure runs the Lua interpreter | ||
BDEPEND=" | ||
sys-devel/autoconf | ||
virtual/pkgconfig | ||
lua? ( ${LUA_DEPS} ) | ||
nls? ( sys-devel/gettext ) | ||
" | ||
PDEPEND="!minimal? ( app-vim/gentoo-syntax )" | ||
|
||
# various failures (bugs #630042 and #682320) | ||
RESTRICT="test" | ||
|
||
pkg_setup() { | ||
# people with broken alphabets run into trouble. bug 82186. | ||
unset LANG LC_ALL | ||
export LC_COLLATE="C" | ||
|
||
use lua && lua-single_pkg_setup | ||
use python && python-single-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
if [[ ${PV} != 9999* ]]; then | ||
# Gentoo patches to fix runtime issues, cross-compile errors, etc | ||
eapply "${WORKDIR}/vim-patches-vim-9.0.0049-patches" | ||
fi | ||
|
||
# Fixup a script to use awk instead of nawk | ||
sed -i -e \ | ||
'1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \ | ||
"${S}"/runtime/tools/mve.awk || die "mve.awk sed failed" | ||
|
||
# Read vimrc and gvimrc from /etc/vim | ||
echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' \ | ||
>> "${S}"/src/feature.h || die "echo failed" | ||
echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' \ | ||
>> "${S}"/src/feature.h || die "echo failed" | ||
|
||
# Use exuberant ctags which installs as /usr/bin/exuberant-ctags. | ||
# Hopefully this pattern won't break for a while at least. | ||
# This fixes bug 29398 (27 Sep 2003 agriffis) | ||
sed -i -e \ | ||
's/\<ctags\("\| [-*.]\)/exuberant-&/g' \ | ||
"${S}"/runtime/doc/syntax.txt \ | ||
"${S}"/runtime/doc/tagsrch.txt \ | ||
"${S}"/runtime/doc/usr_29.txt \ | ||
"${S}"/runtime/menu.vim \ | ||
"${S}"/src/configure.ac || die 'sed failed' | ||
|
||
# Don't be fooled by /usr/include/libc.h. When found, vim thinks | ||
# this is NeXT, but it's actually just a file in dev-libs/9libs | ||
# This fixes bug 43885 (20 Mar 2004 agriffis) | ||
sed -i -e \ | ||
's/ libc\.h / /' "${S}"/src/configure.ac || die 'sed failed' | ||
|
||
# gcc on sparc32 has this, uhm, interesting problem with detecting EOF | ||
# correctly. To avoid some really entertaining error messages about stuff | ||
# which isn't even in the source file being invalid, we'll do some trickery | ||
# to make the error never occur. bug 66162 (02 October 2004 ciaranm) | ||
find "${S}" -name '*.c' | while read c; do | ||
echo >> "$c" || die "echo failed" | ||
done | ||
|
||
# Try to avoid sandbox problems. Bug #114475. | ||
if [[ -d "${S}"/src/po ]]; then | ||
sed -i -e \ | ||
'/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \ | ||
"${S}"/src/po/Makefile || die | ||
fi | ||
|
||
cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed" | ||
|
||
# Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0 | ||
sed -i -e \ | ||
"s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \ | ||
"${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed' | ||
|
||
# Fix bug 18245: Prevent "make" from the following chain: | ||
# (1) Notice configure.ac is newer than auto/configure | ||
# (2) Rebuild auto/configure | ||
# (3) Notice auto/configure is newer than auto/config.mk | ||
# (4) Run ./configure (with wrong args) to remake auto/config.mk | ||
sed -i -e \ | ||
's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed" | ||
rm -v src/auto/configure || die "rm failed" | ||
|
||
# --with-features=huge forces on cscope even if we --disable it. We need | ||
# to sed this out to avoid screwiness. (1 Sep 2004 ciaranm) | ||
if ! use cscope; then | ||
sed -i -e \ | ||
'/# define FEAT_CSCOPE/d' src/feature.h || die "couldn't disable cscope" | ||
fi | ||
|
||
eapply_user | ||
} | ||
|
||
src_configure() { | ||
|
||
# Fix bug 37354: Disallow -funroll-all-loops on amd64 | ||
# Bug 57859 suggests that we want to do this for all archs | ||
filter-flags -funroll-all-loops | ||
|
||
# Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for | ||
# everyone since previous flag filtering bugs have turned out to affect | ||
# multiple archs... | ||
replace-flags -O3 -O2 | ||
|
||
emake -j1 -C src autoconf | ||
|
||
# This should fix a sandbox violation (see bug 24447). The hvc | ||
# things are for ppc64, see bug 86433. | ||
local file | ||
for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do | ||
if [[ -e ${file} ]]; then | ||
addwrite $file | ||
fi | ||
done | ||
|
||
use debug && append-flags "-DDEBUG" | ||
|
||
local myconf=( | ||
--with-features=huge | ||
--disable-gpm | ||
--with-gnome=no | ||
$(use_enable sound canberra) | ||
$(use_enable acl) | ||
$(use_enable crypt libsodium) | ||
$(use_enable cscope) | ||
$(use_enable netbeans) | ||
$(use_enable nls) | ||
$(use_enable perl perlinterp) | ||
$(use_enable python python3interp) | ||
$(use_with python python3-command "${PYTHON}") | ||
$(use_enable racket mzschemeinterp) | ||
$(use_enable ruby rubyinterp) | ||
$(use_enable selinux) | ||
$(use_enable session xsmp) | ||
$(use_enable tcl tclinterp) | ||
) | ||
|
||
if use lua; then | ||
# -DLUA_COMPAT_OPENLIB=1 is required to enable the | ||
# deprecated (in 5.1) luaL_openlib API (#874690) | ||
use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1 | ||
|
||
myconf+=( | ||
--enable-luainterp | ||
$(use_with lua_single_target_luajit luajit) | ||
--with-lua-prefix="${EPREFIX}/usr" | ||
) | ||
fi | ||
|
||
# Default is gtk unless aqua or motif are enabled | ||
echo ; echo | ||
if use aqua; then | ||
einfo "Building gvim with the Carbon GUI" | ||
myconf+=( | ||
--enable-darwin | ||
--enable-gui=carbon | ||
) | ||
elif use motif; then | ||
einfo "Building gvim with the MOTIF GUI" | ||
myconf+=( --enable-gui=motif ) | ||
else | ||
myconf+=( --enable-gtk3-check ) | ||
einfo "Building gvim with the gtk+-3 GUI" | ||
myconf+=( --enable-gui=gtk3 ) | ||
fi | ||
echo ; echo | ||
|
||
# let package manager strip binaries | ||
export ac_cv_prog_STRIP="$(type -P true ) faking strip" | ||
|
||
# keep prefix env contained within the EPREFIX | ||
use prefix && myconf+=( --without-local-dir ) | ||
|
||
if [[ ${CHOST} == *-interix* ]]; then | ||
# avoid finding of this function, to avoid having to patch either | ||
# configure or the source, which would be much more hackish. | ||
# after all vim does it right, only interix is badly broken (again) | ||
export ac_cv_func_sigaction=no | ||
fi | ||
|
||
if tc-is-cross-compiler ; then | ||
export vim_cv_getcwd_broken=no \ | ||
vim_cv_memmove_handles_overlap=yes \ | ||
vim_cv_stat_ignores_slash=yes \ | ||
vim_cv_terminfo=yes \ | ||
vim_cv_toupper_broken=no | ||
fi | ||
|
||
econf \ | ||
--with-modified-by=Gentoo-${PVR} \ | ||
--with-vim-name=gvim \ | ||
--with-x \ | ||
"${myconf[@]}" | ||
} | ||
|
||
src_compile() { | ||
# The following allows emake to be used | ||
emake -j1 -C src auto/osdef.h objects | ||
|
||
emake | ||
} | ||
|
||
src_test() { | ||
einfo | ||
einfo "Starting vim tests. Several error messages will be shown" | ||
einfo "while the tests run. This is normal behaviour and does not" | ||
einfo "indicate a fault." | ||
einfo | ||
ewarn "If the tests fail, your terminal may be left in a strange" | ||
ewarn "state. Usually, running 'reset' will fix this." | ||
einfo | ||
|
||
# Don't let vim talk to X | ||
unset DISPLAY | ||
|
||
# Make gvim not try to connect to X. See :help gui-x11-start in vim for how | ||
# this evil trickery works. | ||
ln -s "${S}"/src/gvim "${S}"/src/testvim || die | ||
|
||
# Make sure our VIMPROG is used. | ||
sed -i -e 's:\.\./vim:../testvim:' src/testdir/test49.vim || die | ||
|
||
# Don't do additional GUI tests. | ||
emake -j1 VIMPROG=../testvim -C src/testdir nongui | ||
} | ||
|
||
# Call eselect vi update with --if-unset | ||
# to respect user's choice (bug 187449) | ||
eselect_vi_update() { | ||
ebegin "Calling eselect vi update" | ||
eselect vi update --if-unset | ||
eend $? | ||
} | ||
|
||
src_install() { | ||
local vimfiles=/usr/share/vim/vim${VIM_VERSION/.} | ||
|
||
dobin src/gvim | ||
dosym gvim /usr/bin/gvimdiff | ||
dosym gvim /usr/bin/evim | ||
dosym gvim /usr/bin/eview | ||
dosym gvim /usr/bin/gview | ||
dosym gvim /usr/bin/rgvim | ||
dosym gvim /usr/bin/rgview | ||
|
||
emake -C src DESTDIR="${D}" DATADIR="${EPREFIX}"/usr/share install-icons | ||
|
||
dodir /usr/share/man/man1 | ||
echo ".so vim.1" > "${ED}"/usr/share/man/man1/gvim.1 || die "echo failed" | ||
echo ".so vim.1" > "${ED}"/usr/share/man/man1/gview.1 || die "echo failed" | ||
echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/gvimdiff.1 || \ | ||
die "echo failed" | ||
|
||
insinto /etc/vim | ||
newins "${FILESDIR}"/gvimrc-r1 gvimrc | ||
eprefixify "${ED}"/etc/vim/gvimrc | ||
|
||
# bash completion script, bug #79018. | ||
newbashcomp "${FILESDIR}"/${PN}-completion ${PN} | ||
|
||
# don't install vim desktop file | ||
rm -v "${ED}"/usr/share/applications/vim.desktop || die "failed to remove vim.desktop" | ||
} | ||
|
||
pkg_postinst() { | ||
# update documentation tags (from vim-doc.eclass) | ||
update_vim_helptags | ||
|
||
# update fdo mime stuff, bug #78394 | ||
xdg_desktop_database_update | ||
|
||
# update icon cache | ||
xdg_icon_cache_update | ||
|
||
# call eselect vi update | ||
eselect_vi_update | ||
} | ||
|
||
pkg_postrm() { | ||
# update documentation tags (from vim-doc.eclass) | ||
update_vim_helptags | ||
|
||
# update fdo mime stuff, bug #78394 | ||
xdg_desktop_database_update | ||
|
||
# update icon cache | ||
xdg_icon_cache_update | ||
|
||
# call eselect vi update | ||
eselect_vi_update | ||
} |