Skip to content

Commit

Permalink
dev-lang/rust-bin: version bump
Browse files Browse the repository at this point in the history
Bump to 1.12.1

Signed-off-by: Doug Goldstein <[email protected]>
  • Loading branch information
cardoe committed Oct 25, 2016
1 parent 0aac304 commit 365445e
Show file tree
Hide file tree
Showing 2 changed files with 104 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-lang/rust-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST rust-1.12.1-i686-unknown-linux-gnu.tar.gz 123818795 SHA256 ede9b9d14d1ddbc29975d1ead73fcf2758719b4b371363afe1c32eb8d6e96bb3 SHA512 8393bd91652ebe2a3a6decdd53bcb388d308a8867736ea68f75c2d073a0356583d90f74ce0af6105bd867ab03feed02af17422f25cf3bbf0601d59062aa1c70a WHIRLPOOL 20fab3b60d94e5e75c086ed86bde745c1a915347f4c0af16d3289c57d6cb4396656e1fd93a52d61ea2425c0e37d7c89c5d7a62ea424cd54f5ef2b4eaf5443e97
DIST rust-1.12.1-x86_64-unknown-linux-gnu.tar.gz 120844880 SHA256 9e546aec13e389429ba2d86c8f4e67eba5af146c979e4faa16ffb40ddaf9984c SHA512 888ad195b9d4b8d1d7ccaffd460e6fe0f6003461a6818937b4b6f80a92462eb96095888729188421f21e6bd0e21fa558a7ea81327b78eab5c3b70807c5069492 WHIRLPOOL 309c0dfbf25a20bf8a48609d83212e29d409b21f51fcc228b2f83242df1486cd65a9fb884e5b3737fbc90db0a59e6b155528b445412466a84988a77b3999bcdc
DIST rust-1.5.0-i686-unknown-linux-gnu.tar.gz 97897323 SHA256 ee45a91c5b1b3542fc349c743667216dec52ea924166ced90675500baf2c42cd SHA512 1fdbb197fc2f28c846da2099e5c671fd165236a0e611eadd9faf07cdd8a3312f0085d992e97da1f97e1e10fb3d9f4d06215208242349a7d7857008d003495eb2 WHIRLPOOL d3a4dd5e002cd85d71648822274e8d4e1085618c38efdda602ab2afe647ad0415360c84fd18a5e1cda544ae54d18daa3a6e6ecd92b7529fb5263a8edcd3577c3
DIST rust-1.5.0-x86_64-unknown-linux-gnu.tar.gz 97177085 SHA256 60b83f74d882ce2ba5bc979b5b0589dca56659f215b3259e7188fed8c50aac9d SHA512 2ccb6fcb7479ce6d7a5c9a55b3dde7dacc723012a8d8065f431492c7060aeb3dcf3c5df120a583aa890c659b08cbd9cb6df0846e936fdb808afb5efb2410e3b6 WHIRLPOOL bd20965ba143ef95ea7da378f8b312bc1f6340635fcbc9ef8c351bf2f5488825d4f96f3b43d5f88dba8587273ea73586e69c5f5adaf88f32fe01f5ffe5100abb
DIST rust-1.6.0-i686-unknown-linux-gnu.tar.gz 99521439 SHA256 4d46ab71e057c66ff6805e5935038371b661aae908bb907d65cedc112bbaa109 SHA512 473a3e946b9d650f157c3eedb926b6f6c657a7116d8c7173417e6ad065f8f504548992eb2f1c0a10f3033d06520da54dba780aabc1921bb264f7b85bc1c416ad WHIRLPOOL ca8ccb07a7c60d0217ddb3a3082d8a0ee99ae7c048f603f3d3fbcd6fc24c8ab959de98e85967bb69a457d37e51677dede4672b6b13502601be105b6e7c1dc2dc
Expand Down
102 changes: 102 additions & 0 deletions dev-lang/rust-bin/rust-bin-1.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils bash-completion-r1

MY_P="rust-${PV}"

DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="http://www.rust-lang.org/"
SRC_URI="amd64? ( http://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux-gnu.tar.gz )
x86? ( http://static.rust-lang.org/dist/${MY_P}-i686-unknown-linux-gnu.tar.gz )"

LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
!dev-lang/rust:0
"
RDEPEND="${DEPEND}"

QA_PREBUILT="
opt/${P}/bin/rustc-bin-${PV}
opt/${P}/bin/rustdoc-bin-${PV}
opt/${P}/lib/*.so
opt/${P}/lib/rustlib/*/lib/*.so
"

src_unpack() {
default

local postfix
use amd64 && postfix=x86_64-unknown-linux-gnu
use x86 && postfix=i686-unknown-linux-gnu
mv "${WORKDIR}/${MY_P}-${postfix}" "${S}" || die
}

src_install() {
local std=$(grep 'std' ./components)
local components="rustc,${std}"
use doc && components="${components},rust-docs"
./install.sh \
--components="${components}" \
--disable-verify \
--prefix="${D}/opt/${P}" \
--mandir="${D}/usr/share/${P}/man" \
--disable-ldconfig \
|| die

local rustc=rustc-bin-${PV}
local rustdoc=rustdoc-bin-${PV}
local rustgdb=rust-gdb-bin-${PV}

mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
mv "${D}/opt/${P}/bin/rust-gdb" "${D}/opt/${P}/bin/${rustgdb}" || die

dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
dosym "/opt/${P}/bin/${rustgdb}" "/usr/bin/${rustgdb}"

cat <<-EOF > "${T}"/50${P}
LDPATH="/opt/${P}/lib"
MANPATH="/usr/share/${P}/man"
EOF
doenvd "${T}"/50${P}

cat <<-EOF > "${T}/provider-${P}"
/usr/bin/rustdoc
/usr/bin/rust-gdb
EOF
dodir /etc/env.d/rust
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
}

pkg_postinst() {
eselect rust update --if-unset

elog "Rust installs a helper script for calling GDB now,"
elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV},"

if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
fi

if has_version app-editors/gvim || has_version app-editors/vim; then
elog "install app-vim/rust-vim to get vim support for rust."
fi

if has_version 'app-shells/zsh'; then
elog "install app-shells/rust-zshcomp to get zsh completion for rust."
fi
}

pkg_postrm() {
eselect rust unset --if-invalid
}

0 comments on commit 365445e

Please sign in to comment.