Skip to content

Commit

Permalink
app-doc/doxygen: add 1.9.2
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Oct 28, 2021
1 parent 3e16a1f commit 3662ee1
Show file tree
Hide file tree
Showing 4 changed files with 173 additions and 5 deletions.
1 change: 1 addition & 0 deletions app-doc/doxygen/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST doxygen-1.8.17.src.tar.gz 5138888 BLAKE2B 79d7d64fe2104f3fc802e9ee8f5fcd13ed4f0e23fe3e8d8013d1724d917d5f4e7d8c2df672e253aa2c8d67e839a6169632ebd87bc281b8ee70d217f486e402f7 SHA512 2fd087d127e301ea48355ea52c9af4f2091df06551cf64da80df81f0758194b296efb1e8d3962867a6a6d2da5a3fc323842f7766a445748005b30097ded30a75
DIST doxygen-1.8.20.src.tar.gz 5132703 BLAKE2B 2a9e6df833c64d7052331b52647943f7eaad8214d66962970ad55628cc2ab26883655908588bee2d4872bb2d6d85f8d18cbb03e7dabe0280f337ab53d8538ec9 SHA512 65d104d25061ee59199c74c0328f59fbeaf14f0dade755187ebd43f59008adfef243d4da448b71ae04dc325b848f9bdd109eb20e6f6092f3ed19862426d060cf
DIST doxygen-1.9.1.src.tar.gz 5117435 BLAKE2B 28c1a1cb8390e17e2b399cea765f837782ee268a999606eef4031a5f65943c793c97bdbd2e2a25a39358ecac5df2c7a62aa4cca72753a924e4e718c512b8a9c7 SHA512 637496c549a4a150cfaeb5d4913de512262145ecd7d455d7b7f3dd68f9416e47d931a6c1efd8a17d931e4baf4a8a9f2ed21124664003b123b6f89ca4abf263ed
DIST doxygen-1.9.2.src.tar.gz 5076037 BLAKE2B 7b21b228a2049f3048fba744d94066524a0fca37335a7ffd2616fd62a8a7d8d9d28d0bd506245c63771264a279a21f327e5386a9b4c490eea7f79ddd9583b566 SHA512 2729d013b0363a919bbf6babd300389b76e95dd9dbb16ac0f57fc5a0392d3e2076ea4fba958a236311513e68e4aa056a77bd22c9c92b410a17eed095e5adccc0
138 changes: 138 additions & 0 deletions app-doc/doxygen/doxygen-1.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,138 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..10} )

inherit cmake flag-o-matic llvm python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
else
SRC_URI="http://doxygen.nl/files/${P}.src.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="http://www.doxygen.org"

LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch qt5 sqlite userland_GNU"
# We need TeX for tests, bug #765472
RESTRICT="!doc? ( test )"

BDEPEND="sys-devel/bison
sys-devel/flex
${PYTHON_DEPS}
"
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
virtual/libiconv
clang? ( >=sys-devel/clang-10:= )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doc? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
dev-texlive/texlive-fontutils
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
dev-texlive/texlive-plaingeneric
)
doxysearch? ( dev-libs/xapian:= )
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
)
sqlite? ( dev-db/sqlite:3 )
"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-1.8.16-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.8.17-ensure_static_support_libraries.patch"
"${FILESDIR}/${PN}-1.9.1-ignore-bad-encoding.patch"
"${FILESDIR}/${PN}-1.9.1-header-dep.patch"
"${FILESDIR}/${P}-xml-static.patch"
)

DOCS=( LANGUAGE.HOWTO README.md )

pkg_setup() {
use clang && llvm_pkg_setup
python-any-r1_pkg_setup
}

src_prepare() {
cmake_src_prepare

# Ensure we link to -liconv
if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
local pro
for pro in */*.pro.in */*/*.pro.in; do
echo "unix:LIBS += -liconv" >> "${pro}" || die
done
fi

# Call dot with -Teps instead of -Tps for EPS generation - bug #282150
sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die

# fix pdf doc
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die

if is-flagq "-O3" ; then
ewarn
ewarn "Compiling with -O3 is known to produce incorrectly"
ewarn "optimized code which breaks doxygen."
ewarn
elog
elog "Continuing with -O2 instead ..."
elog
replace-flags "-O3" "-O2"
fi
}

src_configure() {
local mycmakeargs=(
-Duse_libclang=$(usex clang)
-Dbuild_doc=$(usex doc)
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
-DGIT_EXECUTABLE="false"
)

use doc && mycmakeargs+=(
-DDOC_INSTALL_DIR="share/doc/${P}"
)

cmake_src_configure
}

src_compile() {
cmake_src_compile

if use doc; then
export VARTEXFONTS="${T}/fonts" # bug #564944

if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
|| die "disabling dot failed"
fi

# -j1 for bug #770070
cmake_src_compile docs -j1
fi
}

src_install() {
cmake_src_install
}
10 changes: 5 additions & 5 deletions app-doc/doxygen/doxygen-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
else
SRC_URI="http://doxygen.nl/files/${P}.src.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Documentation system for most programming languages"
Expand Down Expand Up @@ -55,7 +55,6 @@ RDEPEND="app-text/ghostscript-gpl
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.16-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.8.17-ensure_static_support_libraries.patch"
"${FILESDIR}/${PN}-1.9.1-ignore-bad-encoding.patch"
Expand Down Expand Up @@ -117,6 +116,8 @@ src_configure() {
}

src_compile() {
cmake_src_compile

if use doc; then
export VARTEXFONTS="${T}/fonts" # bug #564944

Expand All @@ -126,10 +127,9 @@ src_compile() {
|| die "disabling dot failed"
fi

cmake_src_compile docs
# -j1 for bug #770070
cmake_src_compile docs -j1
fi

cmake_src_compile
}

src_install() {
Expand Down
29 changes: 29 additions & 0 deletions app-doc/doxygen/files/doxygen-1.9.2-xml-static.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
https://github.com/doxygen/doxygen/pull/8862
https://github.com/doxygen/doxygen/issues/8855

[sam: deleted msc hunk b/c we had it in a patch of our
own.]

From 5c3a4ad2773fc911b341b36b00528603afbe1602 Mon Sep 17 00:00:00 2001
From: albert-github <[email protected]>
Date: Wed, 27 Oct 2021 16:41:28 +0200
Subject: [PATCH] issue #8855 Unable to build 1.9.2

All other libraries have been declared STATIC so better to declare the cmls and mscgen libraries also STATIC.
---
libxml/CMakeLists.txt | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/libxml/CMakeLists.txt b/libxml/CMakeLists.txt
index 96c56534f9..596ed90887 100644
--- a/libxml/CMakeLists.txt
+++ b/libxml/CMakeLists.txt
@@ -11,7 +11,7 @@ set_source_files_properties(${GENERATED_SRC}/xml.l.h PROPERTIES GENERATED 1)

FLEX_TARGET(xml xml.l ${GENERATED_SRC}/xml.cpp COMPILE_FLAGS "${LEX_FLAGS}")

-add_library(xml
+add_library(xml STATIC
${GENERATED_SRC}/xml.cpp
${GENERATED_SRC}/xml.l.h
)

0 comments on commit 3662ee1

Please sign in to comment.