Skip to content

Commit

Permalink
dev-ruby/oauth2: add 1.3.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
graaff committed Mar 4, 2017
1 parent f81ba56 commit 36a938e
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/oauth2/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST oauth2-1.2.0.tar.gz 18949 SHA256 e40fb1edaac68cb83bdbd1d6e2a1c485535278124c48f7b2db4771bb03c927d0 SHA512 2adacdc02752289eba217c6b2dfce0d00325becdbb7983b9fdfb149717ffd58cd235217048e48dc5be3d3c4024c224f8164cb0f9b4d792060554fbcb72e70536 WHIRLPOOL 138076cf3509b08ba40041be126d158ebd1767f043c0838789d28b5bce63b6c5ee49c2acfcf9ce81b9cc0303f618035366e947bc4bbd6e242658e973438cf5fc
DIST oauth2-1.3.0.tar.gz 20739 SHA256 fc3c1c5d540a7dbf5363a753052394eb67397590e17b15c1daf2d214ef3a5eaf SHA512 18b7a5055bdbecd1a073b0c7e4f9175b70cf0b6df0f98811d7de4a3ff252b9d2e6319cc3c9d9c3564cfe45a96bbd55a1cf0658dd8080918fc03b14e0f0041c9d WHIRLPOOL b5ad6772fd033342585ba03fd0cbf3a1bd74876ff2027f80e7550f9a50d464d5d89b6b570b7949ffc929fbd36ebe389dbfa8e543e78b8f565546a9cb974c0842
DIST oauth2-1.3.1.tar.gz 21371 SHA256 aee3e9ea7f577650cb0c892fdf9a5318130f7802c9997ff186957fe69b6d7bc1 SHA512 6ea4ce6c711c101f8cfe1450624e5bfe501114dd7888d663e0f5171de9f0efa0957483f1350dfc5bcf5d3a63240b194373df733395fac3fea2fcd55d22e4262a WHIRLPOOL d8dc46a3bfea90937828771a22c216462bd1e38cf8af3152d075359b07a1c60b87d57c57052cb3706c4ef1b03203b16a7a0b0db21e3bfc0a7b138428e4b7b949
41 changes: 41 additions & 0 deletions dev-ruby/oauth2/oauth2-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC="doc:rdoc"

RUBY_FAKEGEM_DOCDIR="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"

inherit ruby-fakegem eutils

DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
HOMEPAGE="https://github.com/intridea/oauth2"
SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
IUSE=""

ruby_add_rdepend ">=dev-ruby/faraday-0.8
>=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
>=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
>=dev-ruby/multi_xml-0.5:0
>=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"

all_ruby_prepare() {
sed -i -e '/simplecov/,/^ end/ s:^:#:' spec/helper.rb || die

sed -i -e '/yardstick/,/^end/ s:^:#:' \
-e '/bundler/I s:^:#:' Rakefile || die
}

each_ruby_test() {
CI=true ${RUBY} -S rspec spec || die
}

0 comments on commit 36a938e

Please sign in to comment.