Skip to content

Commit

Permalink
dev-java/bcprov: Revert previous commit.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.18
RepoMan-Options: --force
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Sep 5, 2015
1 parent 89b9d42 commit 36ba52d
Showing 1 changed file with 57 additions and 0 deletions.
57 changes: 57 additions & 0 deletions dev-java/bcprov/bcprov-1.38-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-ant-2

MY_P="${PN}-jdk14-${PV/./}"
DESCRIPTION="Java cryptography APIs"
HOMEPAGE="http://www.bouncycastle.org/java.html"
SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"

# The src_unpack find needs a new find
# https://bugs.gentoo.org/show_bug.cgi?id=182276
DEPEND=">=virtual/jdk-1.4
userland_GNU? ( >=sys-apps/findutils-4.3 )
app-arch/unzip"
RDEPEND=">=virtual/jre-1.4"

IUSE="userland_GNU"

S="${WORKDIR}/${MY_P}"

src_unpack() {
unpack ${A}
cd "${S}"
unpack ./src.zip

# so that we don't need junit
echo "Removing testcases' sources:"
find . -path '*test/*.java' -print -delete \
|| die "Failed to delete testcases."
find . -name '*Test*.java' -print -delete \
|| die "Failed to delete testcases."
}

src_compile() {
mkdir "${S}/classes"

find . -name "*.java" > "${T}/src.list"
ejavac -encoding ISO-8859-1 -d "${S}/classes" "@${T}/src.list"

cd "${S}/classes"
jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
}

src_install() {
java-pkg_dojar "${S}/${PN}.jar"

use source && java-pkg_dosrc org
use doc && java-pkg_dojavadoc docs
}

0 comments on commit 36ba52d

Please sign in to comment.