forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-apps: Move 15.08.3 kdeartwork and kdegraphics from overlay
Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
45 changed files
with
611 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gwenview-15.08.3.tar.xz 2922708 SHA256 6622d11379e403ea78ec75fdf37b4460843ecd50b07e68c88f74efa8a780bcb9 SHA512 46736e67bd11f417d7599bd9ee1948af901af4dae7b8cd5837da0613ba70e5e848a3dade2d90a80d68e337ca236bababca050eddb799d37c4e4cb18d87f68e15 WHIRLPOOL 45869d6f12b26443da7550ce9ea3de06471b250e0c766bc22284496d5b3fc8908053b652ccf86370c6ea5dd17215f59f3a5dad82440a77ac0c3a3e64f1b1a601 | ||
DIST gwenview-4.14.3.tar.xz 2910652 SHA256 2032d18bc20ea490f3d1298e015ffac2a7b96eb7a76c02578df0713c1ab427a0 SHA512 cb64b2278adb01f0fad92d861126ff8256c80ae8780de0a37bcc1e6a0e19e2f5b14c09fc884c6d759a0cd6b3a2611787235020745147c9fc66883d61ab4861c3 WHIRLPOOL 6e786942bfb45965af7f765961822b7d2d0929facede5e197a36d67b82aaa3a036261288738fedec33e65ad117a4f14009f59eddb3f89d07ea9584f72fce103f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,91 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KDE_HANDBOOK="true" | ||
KDE_TEST="true" | ||
inherit kde5 | ||
|
||
DESCRIPTION="KDE image viewer" | ||
HOMEPAGE=" | ||
https://www.kde.org/applications/graphics/gwenview/ | ||
https://userbase.kde.org/Gwenview | ||
" | ||
KEYWORDS=" ~amd64 ~x86" | ||
IUSE="kipi raw semantic-desktop X" | ||
|
||
# requires running environment | ||
RESTRICT="test" | ||
|
||
COMMON_DEPEND=" | ||
$(add_frameworks_dep kactivities) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kdelibs4support) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kitemmodels) | ||
$(add_frameworks_dep kitemviews) | ||
$(add_frameworks_dep kjobwidgets) | ||
$(add_frameworks_dep knotifications) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep kservice) | ||
$(add_frameworks_dep ktextwidgets) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
dev-qt/qtgui:5 | ||
dev-qt/qtopengl:5 | ||
dev-qt/qtprintsupport:5 | ||
dev-qt/qtsvg:5 | ||
dev-qt/qtwidgets:5 | ||
media-gfx/exiv2:= | ||
media-libs/lcms:2 | ||
media-libs/libpng:0= | ||
media-libs/phonon[qt5] | ||
virtual/jpeg:0 | ||
kipi? ( $(add_kdeapps_dep libkipi) ) | ||
raw? ( $(add_kdeapps_dep libkdcraw) ) | ||
semantic-desktop? ( | ||
$(add_frameworks_dep baloo) | ||
$(add_frameworks_dep kfilemetadata) | ||
) | ||
X? ( | ||
dev-qt/qtx11extras:5 | ||
x11-libs/libX11 | ||
) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
dev-qt/qtconcurrent:5 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
$(add_frameworks_dep kimageformats) | ||
dev-qt/qtimageformats:5 | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-15.08.3-fix-libkipi.patch" ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package kipi KF5Kipi) | ||
$(cmake-utils_use_find_package raw KF5KDcraw) | ||
$(cmake-utils_use_find_package X X11) | ||
) | ||
|
||
# Workaround for bug #479510 | ||
if [[ -e ${EPREFIX}/usr/include/${CHOST}/jconfig.h ]]; then | ||
mycmakeargs+=( -DJCONFIG_H="${EPREFIX}/usr/include/${CHOST}/jconfig.h" ) | ||
fi | ||
|
||
if use semantic-desktop; then | ||
mycmakeargs+=(-DGWENVIEW_SEMANTICINFO_BACKEND=Baloo) | ||
else | ||
mycmakeargs+=(-DGWENVIEW_SEMANTICINFO_BACKEND=None) | ||
fi | ||
|
||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,8 @@ | ||
<?xml version='1.0' encoding='UTF-8'?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<herd>kde</herd> | ||
<use> | ||
<flag name="kipi">Support for the KDE Image Plugin Interface.</flag> | ||
<flag name="kipi">Support for the KDE Image Plugin Interface</flag> | ||
</use> | ||
<herd>kde</herd> | ||
<upstream> | ||
<remote-id type="sourceforge">gwenview</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kamera-15.08.3.tar.xz 35460 SHA256 1fa27239a84ce6a224afd4f327813625a3f05717b852503fc55914a557e79eca SHA512 c68486a46555f29ddae89529c30f387676c13f48aa9b2064582d4e6319eaec1c7b48e13218777711faddf20e7d45e89ec582d044ef9e4117b8e449a0e5a22488 WHIRLPOOL d51d5f8877c446610e84d7f5b6ae477f6cc800ccdb2b256d463e8ddf7abd64a1ed3b4fa1861090fd38772086842057ce25451600a654543ef42056e4b2914857 | ||
DIST kamera-4.14.3.tar.xz 35324 SHA256 6f0beae8b6e55aa6313d34d7478a6a7b80a0a4c1e2c874b5ebddd00d430bc126 SHA512 fbdbc8236bb870ca02bc34a4b2b787380e5ec50658b2e6d157725e1cf5e202366fc4d0e6146098b59af9cb82a82a04f62e2d7c8262972a1da468f89e5bd48129 WHIRLPOOL 48d83b8120d31f76f21ecfdb4c9f94b941ec9a0f0371ead4dba714e64c12e3f971a4fa04805f7a7f98ad8f5ba0b32ee791547e063ecd321cd97bce674a73296e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KDE_HANDBOOK="optional" | ||
inherit kde4-base | ||
|
||
DESCRIPTION="KDE digital camera manager" | ||
KEYWORDS=" ~amd64 ~x86" | ||
IUSE="debug" | ||
|
||
DEPEND=" | ||
media-libs/libgphoto2:= | ||
" | ||
RDEPEND="${DEPEND}" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kcolorchooser-15.08.3.tar.xz 4308 SHA256 c12ec30771d6b09cc9941d41c0eceb577643297f7d9896a9a3a5f6431aa9d2f3 SHA512 9c13f3d0cbff5d40bde14758739f2c0fe5318ba3b1a159821b541360e6af3156d4514f840ada426ddaeff1d7ade71802d17565ad3f3d925c750c7fb777e4fa8b WHIRLPOOL 1e9c17b758ce7f76cf4d53817814c17a7eb4c0b501d6531699c7f870c6e95c799cac8e7e0e4864c9831b392ef0ed55a6a332c35a9ba0c5bee0b4793576850e46 | ||
DIST kcolorchooser-4.14.3.tar.xz 4376 SHA256 4a246a5ff60fb06c7febe492858b89a8d0bd50689318d86183dcd8be49b5bafc SHA512 e3176724dd7f55f7a41364f3ec39850cb1135042851c12b053637ef9870e980a1a570866e0ae2a86ea59a236704c53871b3035d54df486f0b705c8b3261026e3 WHIRLPOOL fd6e9a8b25d0abe287ea29c35a948d47c87587d7c75ead097533cd121d533df05945a1ff8dcf1dc16a86db6aacce5985bc1212b7ebfcb7cfdf51bc8e8cebb938 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit kde4-base | ||
|
||
DESCRIPTION="KDE color selector/editor" | ||
HOMEPAGE="https://www.kde.org/applications/graphics/kcolorchooser/" | ||
KEYWORDS=" ~amd64 ~x86" | ||
IUSE="debug" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
14 changes: 14 additions & 0 deletions
14
kde-apps/kdeartwork-colorschemes/kdeartwork-colorschemes-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMNAME="kdeartwork" | ||
KMMODULE="ColorSchemes" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="KDE extra colorschemes" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
14 changes: 14 additions & 0 deletions
14
kde-apps/kdeartwork-desktopthemes/kdeartwork-desktopthemes-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMMODULE="desktopthemes" | ||
KMNAME="kdeartwork" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Additional KDE4 Plasma themes" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
16 changes: 16 additions & 0 deletions
16
kde-apps/kdeartwork-emoticons/kdeartwork-emoticons-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
RESTRICT="binchecks strip" | ||
|
||
KMMODULE="emoticons" | ||
KMNAME="kdeartwork" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="EmotIcons (icons for things like smilies :-) for kde" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
19 changes: 19 additions & 0 deletions
19
kde-apps/kdeartwork-iconthemes/kdeartwork-iconthemes-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMNAME="kdeartwork" | ||
KMMODULE="IconThemes" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Icon themes for kde" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
# Provides nuvola icon theme | ||
RDEPEND=" | ||
!x11-themes/nuvola | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
10 changes: 10 additions & 0 deletions
10
kde-apps/kdeartwork-kscreensaver/files/kdeartwork-kscreensaver-15.08.3-missing-include.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- a/CMakeLists.txt 2015-11-15 22:33:19.528585331 +0100 | ||
+++ b/CMakeLists.txt 2015-11-15 22:35:45.976754477 +0100 | ||
@@ -6,6 +6,7 @@ | ||
find_package(KDE4 REQUIRED) | ||
include (KDE4Defaults) | ||
include (MacroLibrary) | ||
+include (CheckIncludeFiles) | ||
|
||
add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS}) | ||
add_definitions( -DQT_NO_CAST_FROM_ASCII ) |
49 changes: 49 additions & 0 deletions
49
kde-apps/kdeartwork-kscreensaver/kdeartwork-kscreensaver-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMMODULE="kscreensaver" | ||
KMNAME="kdeartwork" | ||
OPENGL_REQUIRED="optional" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Extra screensavers for kde" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug +eigen +kexiv2 xscreensaver" | ||
|
||
# libkworkspace - only as a stub to provide KDE4Workspace config | ||
RDEPEND=" | ||
$(add_kdebase_dep kscreensaver '' 4.11) | ||
$(add_kdebase_dep libkworkspace '' 4.11) | ||
media-libs/libart_lgpl | ||
x11-libs/libX11 | ||
x11-libs/libXt | ||
virtual/glu | ||
virtual/opengl | ||
kexiv2? ( $(add_kdeapps_dep libkexiv2) ) | ||
xscreensaver? ( x11-misc/xscreensaver ) | ||
" | ||
DEPEND="${RDEPEND} | ||
eigen? ( dev-cpp/eigen:2 ) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-xscreensaver.patch" | ||
"${FILESDIR}/${PN}-4.5.95-webcollage.patch" | ||
"${FILESDIR}/${PN}-15.08.3-missing-include.patch" | ||
) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DKSCREENSAVER_SOUND_SUPPORT=ON | ||
-DOPENGL=ON | ||
$(cmake-utils_use_with eigen Eigen2) | ||
$(cmake-utils_use_with kexiv2) | ||
$(cmake-utils_use_with xscreensaver) | ||
) | ||
|
||
kde4-meta_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit kde5-meta-pkg | ||
|
||
DESCRIPTION="kdeartwork - merge this to pull in all kdeartwork-derived packages" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="minimal" | ||
|
||
RDEPEND=" | ||
$(add_kdeapps_dep kdeartwork-colorschemes) | ||
$(add_kdeapps_dep kdeartwork-desktopthemes) | ||
$(add_kdeapps_dep kdeartwork-emoticons) | ||
$(add_kdeapps_dep kdeartwork-iconthemes) | ||
$(add_kdeapps_dep kdeartwork-kscreensaver) | ||
$(add_kdeapps_dep kdeartwork-wallpapers) | ||
$(add_kdeapps_dep kdeartwork-weatherwallpapers) | ||
!minimal? ( $(add_kdeapps_dep kdeartwork-styles) ) | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
23 changes: 23 additions & 0 deletions
23
kde-apps/kdeartwork-styles/kdeartwork-styles-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,23 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMMODULE="styles" | ||
KMNAME="kdeartwork" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Extra KWin styles and window decorations" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug" | ||
|
||
DEPEND=" | ||
$(add_kdebase_dep kwin '' 4.11) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
KMEXTRA=" | ||
kwin-styles/ | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
20 changes: 20 additions & 0 deletions
20
kde-apps/kdeartwork-wallpapers/kdeartwork-wallpapers-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
RESTRICT="binchecks strip" | ||
|
||
KMMODULE="wallpapers" | ||
KMNAME="kdeartwork" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Wallpapers from kde" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
KMEXTRA=" | ||
HighResolutionWallpapers/ | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kdeartwork-15.08.3.tar.xz 140847804 SHA256 fb3fe3a0502de6e5e3acc4a6bab5b11e861fa596cc3f8acf2f4f86451c003b0c SHA512 780a7f8bd3f897907adc2d3573145b9cf52a740488fc604cd2d5b9e84e172b25a4d7824f30c77bec398a92db688e18f937d44912c033c90dd86ef4ef9fc9b520 WHIRLPOOL 312d2b3d7ccba86ae9368a210b6fb92e69af51e17c118846e05e2cc8efde55484511f2c18b39068b25ea9834173514a3293425d27fa8dbee908743b9e2a5ee71 | ||
DIST kdeartwork-4.14.3.tar.xz 140848704 SHA256 93dce7cbde334b31f07d7ebfcc00b3431695f685f8ccd9c8ef8f94d883f80ef4 SHA512 5b5b403adc9aca2258fd85d7577fdb960bba35dcf22340f79f2ebf26abdea908e35da767be8b20bf3fde4c62afa9f8a05b6df07661b750cc36054480850474fd WHIRLPOOL dac467bb7ca728efab21fb18ef5241f9cd382f8ae32156fb8e2946f1dff0d9d48a6e8a6b64bd8c1e2508cf10a3c89d986a30cc38612a4458763c42714c4d59a6 |
18 changes: 18 additions & 0 deletions
18
kde-apps/kdeartwork-weatherwallpapers/kdeartwork-weatherwallpapers-15.08.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMNAME="kdeartwork" | ||
KMMODULE="WeatherWallpapers" | ||
KDE_SCM="svn" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Weather aware wallpapers. Changes with weather outside" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
$(add_kdeapps_dep kdeartwork-wallpapers) | ||
" |
Oops, something went wrong.