Skip to content

Commit

Permalink
rev bump to make automagic dep on media-libs/gd a user knob (bug #567…
Browse files Browse the repository at this point in the history
…852)

Package-Manager: portage-2.2.20.1
  • Loading branch information
Michael Sterrett committed Dec 9, 2015
1 parent fca7377 commit 36ef1d0
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
51 changes: 51 additions & 0 deletions games-emulation/fceux/fceux-2.2.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils scons-utils games

DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
HOMEPAGE="http://fceux.com/"
SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk logo +lua +opengl"

DEPEND="lua? ( dev-lang/lua:0 )
media-libs/libsdl[opengl?,video]
logo? ( media-libs/gd[png] )
opengl? ( virtual/opengl )
gtk? ( x11-libs/gtk+:3 )
sys-libs/zlib[minizip]"
RDEPEND=${DEPEND}

src_prepare() {
epatch "${FILESDIR}"/${P}-warnings.patch
}

src_compile() {
escons \
GTK=0 \
CREATE_AVI=1 \
SYSTEM_LUA=1 \
SYSTEM_MINIZIP=1 \
$(use_scons gtk GTK3) \
$(use_scons logo LOGO) \
$(use_scons opengl OPENGL) \
$(use_scons lua LUA)
}

src_install() {
dogamesbin bin/fceux

doman documentation/fceux.6
docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
make_desktop_entry fceux FCEUX
doicon fceux.png
prepgamesdirs
}
3 changes: 3 additions & 0 deletions games-emulation/fceux/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
<use>
<flag name="logo">Enable the ability to add a logo screen when creating AVIs</flag>
</use>
<upstream>
<remote-id type="sourceforge">fceultra</remote-id>
</upstream>
Expand Down

0 comments on commit 36ef1d0

Please sign in to comment.