Skip to content

Commit

Permalink
x11-libs/libva-intel-driver: new version 2.4.1
Browse files Browse the repository at this point in the history
Closes: gentoo#16465
Closes: https://bugs.gentoo.org/707934
Signed-off-by: Denis Reva <[email protected]>
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
RarogCmex authored and mattst88 committed Jul 9, 2020
1 parent 26b0b31 commit 3720171
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-libs/libva-intel-driver/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST intel-vaapi-driver-2.3.0.tar.bz2 2901075 BLAKE2B 606635c2b4ad05119a3fe1269354e2a27b944c56117360b5c4171b679506f3aa10d48057f1c99957efa1cff3b625a315138ac93e616aa14d30d20d540a3bb6a8 SHA512 60f37c09269e6ae07e55ecfc2c046ae7b6321abe71647625310ea7c75627ea875b94ed8e14813a36ec068bbd605c6d447dfa2c3bd692eb7953a58a871064fd5b
DIST intel-vaapi-driver-2.4.0.pre1.tar.bz2 2888363 BLAKE2B fc7861e5d7625ed598feadc3b5649335c4f6bc0cacd66bdc38a58bbe4d95909c27c9b84478abdda687725070fa9fea850b3d86925ae6a7ea821a168e2bb98a13 SHA512 f637ca24b34573ae022f24f0352be8a6e2904a703ccfa005fb84da00c54e9e02ff0282e882312b86dd7e2d1a1611fba3eef37909ac66a3c2beb056d8cba6019f
DIST intel-vaapi-driver-2.4.1.tar.bz2 2889762 BLAKE2B 25888ac7a1a42233c4b0269bd910c5161f99bf22c932b46e20c8c77ed0404bf99702dd9f11b73bc0fd76a3b012ffa1de6c6133cbd7be880428235de9cfcc6ad8 SHA512 1e9dc81ecd0b3640fccd1fb827a0ade0a1e5bbabe375130df159849e47ce98c8e879c65ddaaae11d16e916be76b507be69bc0c813494e37e7fca86b0b897a94f
54 changes: 54 additions & 0 deletions x11-libs/libva-intel-driver/libva-intel-driver-2.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN="intel-vaapi-driver"
if [[ ${PV} = *9999* ]] ; then # Live ebuild
inherit git-r3
EGIT_REPO_URI="https://github.com/intel/intel-vaapi-driver"
fi

inherit autotools multilib-minimal

DESCRIPTION="HW video decode support for Intel integrated graphics"
HOMEPAGE="https://github.com/intel/intel-vaapi-driver"
if [[ ${PV} != *9999* ]] ; then
SRC_URI="https://github.com/intel/${MY_PN}/releases/download/${PV}/${MY_PN}-${PV}.tar.bz2"
S="${WORKDIR}/${MY_PN}-${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi

LICENSE="MIT"
SLOT="0"
IUSE="wayland X"
RESTRICT="test" # No tests

RDEPEND="
>=x11-libs/libdrm-2.4.52[video_cards_intel,${MULTILIB_USEDEP}]
>=x11-libs/libva-2.4.0:=[X?,wayland?,drm,${MULTILIB_USEDEP}]
wayland? (
>=dev-libs/wayland-1.11[${MULTILIB_USEDEP}]
>=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_prepare() {
eapply_user
sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die
eautoreconf
}

multilib_src_configure() {
local myconf=(
$(use_enable wayland)
$(use_enable X x11)
)
ECONF_SOURCE="${S}" econf "${myconf[@]}"
}

multilib_src_install_all() {
find "${D}" -name "*.la" -delete || die
}

0 comments on commit 3720171

Please sign in to comment.