forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/portage: version bump to 2.3.41
#600804 - revert portage uid/gid mapping behavior for PMS #656542 - ebuild command PermissionError from prepare_build_dirs #657422 - "[Errno 7] Argument list too long" with --usepkgonly #658322 - support trailing slash in INSTALL_MASK patterns #658684 - fix emerge hang after unhandled exception with no tty #658806 - compress-build-logs EOFError #659228 - fix QA_FLAGS_IGNORED for EAPI 7 Package-Manager: Portage-2.3.41, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
285 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,284 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( | ||
pypy | ||
python3_4 python3_5 python3_6 | ||
python2_7 | ||
) | ||
PYTHON_REQ_USE='bzip2(+),threads(+)' | ||
|
||
inherit distutils-r1 systemd | ||
|
||
DESCRIPTION="Portage is the package management and distribution system for Gentoo" | ||
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage" | ||
|
||
LICENSE="GPL-2" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd" | ||
SLOT="0" | ||
IUSE="build doc epydoc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr" | ||
|
||
DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') ) | ||
>=app-arch/tar-1.27 | ||
dev-lang/python-exec:2 | ||
>=sys-apps/sed-4.0.5 sys-devel/patch | ||
doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 ) | ||
epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )" | ||
# Require sandbox-2.2 for bug #288863. | ||
# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's | ||
# quite slow, so it's not considered in the dependencies as an alternative to | ||
# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so | ||
# for now, don't pull in xattr deps for other kernels. | ||
# For whirlpool hash, require python[ssl] (bug #425046). | ||
# For compgen, require bash[readline] (bug #445576). | ||
# app-portage/gemato goes without PYTHON_USEDEP since we're calling | ||
# the executable. | ||
RDEPEND=" | ||
>=app-arch/tar-1.27 | ||
dev-lang/python-exec:2 | ||
!build? ( | ||
>=sys-apps/sed-4.0.5 | ||
app-shells/bash:0[readline] | ||
>=app-admin/eselect-1.2 | ||
$(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' \ | ||
python{2_7,3_4,3_5} pypy) | ||
rsync-verify? ( | ||
>=app-portage/gemato-12.1[${PYTHON_USEDEP}] | ||
app-crypt/openpgp-keys-gentoo-release | ||
>=app-crypt/gnupg-2.2.4-r2[ssl(-)] | ||
) | ||
) | ||
elibc_FreeBSD? ( sys-freebsd/freebsd-bin ) | ||
elibc_glibc? ( >=sys-apps/sandbox-2.2 ) | ||
elibc_musl? ( >=sys-apps/sandbox-2.2 ) | ||
elibc_uclibc? ( >=sys-apps/sandbox-2.2 ) | ||
>=app-misc/pax-utils-0.1.17 | ||
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] ) | ||
xattr? ( kernel_linux? ( | ||
>=sys-apps/install-xattr-0.3 | ||
$(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \ | ||
python2_7 pypy) | ||
) ) | ||
!<app-admin/logrotate-3.8.0" | ||
PDEPEND=" | ||
!build? ( | ||
>=net-misc/rsync-2.6.4 | ||
userland_GNU? ( >=sys-apps/coreutils-6.4 ) | ||
)" | ||
# coreutils-6.4 rdep is for date format in emerge-webrsync #164532 | ||
# NOTE: FEATURES=installsources requires debugedit and rsync | ||
|
||
REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )" | ||
|
||
SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives" | ||
|
||
prefix_src_archives() { | ||
local x y | ||
for x in ${@}; do | ||
for y in ${SRC_ARCHIVES}; do | ||
echo ${y}/${x} | ||
done | ||
done | ||
} | ||
|
||
TARBALL_PV=${PV} | ||
SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2 | ||
$(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)" | ||
|
||
pkg_setup() { | ||
use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 ) | ||
} | ||
|
||
python_prepare_all() { | ||
distutils-r1_python_prepare_all | ||
|
||
if use gentoo-dev; then | ||
einfo "Disabling --dynamic-deps by default for gentoo-dev..." | ||
sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \ | ||
-i pym/_emerge/create_depgraph_params.py || \ | ||
die "failed to patch create_depgraph_params.py" | ||
|
||
einfo "Enabling additional FEATURES for gentoo-dev..." | ||
echo 'FEATURES="${FEATURES} ipc-sandbox network-sandbox strict-keepdir"' \ | ||
>> cnf/make.globals || die | ||
fi | ||
|
||
if use native-extensions; then | ||
printf "[build_ext]\nportage-ext-modules=true\n" >> \ | ||
setup.cfg || die | ||
fi | ||
|
||
if ! use ipc ; then | ||
einfo "Disabling ipc..." | ||
sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \ | ||
-i pym/_emerge/AbstractEbuildProcess.py || \ | ||
die "failed to patch AbstractEbuildProcess.py" | ||
fi | ||
|
||
if use xattr && use kernel_linux ; then | ||
einfo "Adding FEATURES=xattr to make.globals ..." | ||
echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \ | ||
|| die "failed to append to make.globals" | ||
fi | ||
|
||
if use build || ! use rsync-verify; then | ||
sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \ | ||
-i cnf/repos.conf || die "sed failed" | ||
fi | ||
|
||
if [[ -n ${EPREFIX} ]] ; then | ||
einfo "Setting portage.const.EPREFIX ..." | ||
sed -e "s|^\(SANDBOX_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/sandbox\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(FAKEROOT_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/fakeroot\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(BASH_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/bash\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(MOVE_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/mv\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(PRELINK_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/sbin/prelink\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(EPREFIX[[:space:]]*=[[:space:]]*\"\).*|\\1${EPREFIX}\"|" \ | ||
-i pym/portage/const.py || \ | ||
die "Failed to patch portage.const.EPREFIX" | ||
|
||
einfo "Prefixing shebangs ..." | ||
while read -r -d $'\0' ; do | ||
local shebang=$(head -n1 "$REPLY") | ||
if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then | ||
sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \ | ||
die "sed failed" | ||
fi | ||
done < <(find . -type f -print0) | ||
|
||
einfo "Adjusting make.globals ..." | ||
sed -e "s|\(/usr/portage\)|${EPREFIX}\\1|" \ | ||
-e "s|^\(PORTAGE_TMPDIR=\"\)\(/var/tmp\"\)|\\1${EPREFIX}\\2|" \ | ||
-i cnf/make.globals || die "sed failed" | ||
|
||
einfo "Adjusting repos.conf ..." | ||
sed -e "s|^\(location = \)\(/usr/portage\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(sync-openpgp-key-path = \)\(.*\)|\\1${EPREFIX}\\2|" \ | ||
-i cnf/repos.conf || die "sed failed" | ||
if use prefix-guest ; then | ||
sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \ | ||
-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \ | ||
-e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \ | ||
-i cnf/repos.conf || die "sed failed" | ||
fi | ||
|
||
einfo "Adding FEATURES=force-prefix to make.globals ..." | ||
echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \ | ||
|| die "failed to append to make.globals" | ||
fi | ||
|
||
cd "${S}/cnf" || die | ||
if [ -f "make.conf.example.${ARCH}".diff ]; then | ||
patch make.conf.example "make.conf.example.${ARCH}".diff || \ | ||
die "Failed to patch make.conf.example" | ||
else | ||
eerror "" | ||
eerror "Portage does not have an arch-specific configuration for this arch." | ||
eerror "Please notify the arch maintainer about this issue. Using generic." | ||
eerror "" | ||
fi | ||
} | ||
|
||
python_compile_all() { | ||
local targets=() | ||
use doc && targets+=( docbook ) | ||
use epydoc && targets+=( epydoc ) | ||
|
||
if [[ ${targets[@]} ]]; then | ||
esetup.py "${targets[@]}" | ||
fi | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
python_install() { | ||
# Install sbin scripts to bindir for python-exec linking | ||
# they will be relocated in pkg_preinst() | ||
distutils-r1_python_install \ | ||
--system-prefix="${EPREFIX}/usr" \ | ||
--bindir="$(python_get_scriptdir)" \ | ||
--docdir="${EPREFIX}/usr/share/doc/${PF}" \ | ||
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \ | ||
--portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \ | ||
--sbindir="$(python_get_scriptdir)" \ | ||
--sysconfdir="${EPREFIX}/etc" \ | ||
"${@}" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
local targets=() | ||
use doc && targets+=( | ||
install_docbook | ||
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" | ||
) | ||
use epydoc && targets+=( | ||
install_epydoc | ||
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" | ||
) | ||
|
||
# install docs | ||
if [[ ${targets[@]} ]]; then | ||
esetup.py "${targets[@]}" | ||
fi | ||
|
||
systemd_dotmpfilesd "${FILESDIR}"/portage-ccache.conf | ||
|
||
# Due to distutils/python-exec limitations | ||
# these must be installed to /usr/bin. | ||
local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld' | ||
einfo "Moving admin scripts to the correct directory" | ||
dodir /usr/sbin | ||
for target in ${sbin_relocations}; do | ||
einfo "Moving /usr/bin/${target} to /usr/sbin/${target}" | ||
mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!" | ||
done | ||
} | ||
|
||
pkg_preinst() { | ||
# comment out sanity test until it is fixed to work | ||
# with the new PORTAGE_PYM_PATH | ||
#if [[ $ROOT == / ]] ; then | ||
## Run some minimal tests as a sanity check. | ||
#local test_runner=$(find "${ED}" -name runTests) | ||
#if [[ -n $test_runner && -x $test_runner ]] ; then | ||
#einfo "Running preinst sanity tests..." | ||
#"$test_runner" || die "preinst sanity tests failed" | ||
#fi | ||
#fi | ||
|
||
# elog dir must exist to avoid logrotate error for bug #415911. | ||
# This code runs in preinst in order to bypass the mapping of | ||
# portage:portage to root:root which happens after src_install. | ||
keepdir /var/log/portage/elog | ||
# This is allowed to fail if the user/group are invalid for prefix users. | ||
if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then | ||
chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog} | ||
fi | ||
|
||
if has_version ">=${CATEGORY}/${PN}-2.3.1" && \ | ||
has_version "<${CATEGORY}/${PN}-2.3.3"; then | ||
SYNC_DEPTH_UPGRADE=true | ||
else | ||
SYNC_DEPTH_UPGRADE=false | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
if ${SYNC_DEPTH_UPGRADE}; then | ||
ewarn "Please note that this release no longer respects sync-depth for" | ||
ewarn "git repositories. There have been too many problems and" | ||
ewarn "performance issues. See bugs 552814, 559008" | ||
fi | ||
einfo "" | ||
einfo "This release of portage NO LONGER contains the repoman code base." | ||
einfo "Repoman has its own ebuild and release package." | ||
einfo "For repoman functionality please emerge app-portage/repoman" | ||
einfo "Please report any bugs you may encounter." | ||
einfo "" | ||
} |