Skip to content

Commit

Permalink
mail-client/roundcube: Bump to 1.4.7
Browse files Browse the repository at this point in the history
 - 1.4.7 ebuild is just a copy of 1.4.6's.
 - Added <stabilize-allarches/> to metadata.xml

Bug: https://bugs.gentoo.org/731080
Closes: gentoo#16660
Package-Manager: Portage-2.3.99, Repoman-2.3.23
Signed-off-by: Philippe Chaintreuil <[email protected]>
Closes: gentoo#16660
Signed-off-by: Aaron W. Swenson <[email protected]>
  • Loading branch information
Philippe23 authored and titanofold committed Jul 24, 2020
1 parent 982e606 commit 37285d8
Show file tree
Hide file tree
Showing 3 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/roundcube/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST roundcubemail-1.3.11-complete.tar.gz 5492078 BLAKE2B 465d2ecf842c7393bc0bdf8b43d5e63b58e25ea360c1a8c93ccda8b350642dec34512090469720083d30212a31c3d9d7d56aa7df55cae167154bea96cdd19dc3 SHA512 5eb200b58bb289af7432c685eb1feaa2f8fbea56413efd05cf7cf9a4369551d889200b583f04c01c092d8d4c551151fe1051fbe901b02fa2fb26f7ade1c571a2
DIST roundcubemail-1.4.4-complete.tar.gz 7029864 BLAKE2B 2a6764a65c29e3deac6275c3dfd19ab2bee1f33ae1a7767561fcac25688bb8f3f7eeaee3eece20d2a6210aff18a5e493d0be709f4a3ae2ad4f3cfd9a1b124f06 SHA512 ddea321b5266c547f67c010147e9aa1457bea4802bec37f9e9d87e691bdc8df27f5c90cff8770de2458822160b85f7359f62742072ae1d642a040b9d88651519
DIST roundcubemail-1.4.6-complete.tar.gz 7031573 BLAKE2B 541147faeb2fafbf15fd3a4f42a5ecbb642113f02ea9135c91d3b359ec4582e490b80b2e20efa1f6afe8c35e5afe2263682a717a5342198a9eabb7e555e302bb SHA512 e86763ced58cfa8174f71d33ae45cd62f26a58853b9361b800003fa5bf883a4106c957f66b6b17b03172a3ee595ca74d7c19ac38e449a23377defd77cf555742
DIST roundcubemail-1.4.7-complete.tar.gz 7031947 BLAKE2B eec5295c68b7b8f7a652bc6e4ddbb56fbf68e9d1fc01ed75ac8ec33434f299b02e46a8b7f21c56e87ebf9cb0ffa8d105e5e3d9fbcaaab26844c7ed439908bea4 SHA512 d668075c1fb1ac48931a82ca67b4ebeed6f1d1e82a336901f79967cb2eb91979fc7bb46d4895558f8e64f89f963002efc7c1ad23b93c52a252ce1a7aa04b678a
1 change: 1 addition & 0 deletions mail-client/roundcube/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -29,4 +29,5 @@
book server
</flag>
</use>
<stabilize-allarches/>
</pkgmetadata>
73 changes: 73 additions & 0 deletions mail-client/roundcube/roundcube-1.4.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit webapp

MY_PN=${PN}mail
MY_PV=${PV/_/-}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
HOMEPAGE="https://roundcube.net"
SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"

# roundcube is GPL-licensed, the rest of the licenses here are
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"

IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
REQUIRED_USE="|| ( mysql postgres sqlite )"

# this function only sets DEPEND so we need to include that in RDEPEND
need_httpd_cgi

RDEPEND="
${DEPEND}
>=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]
)
enigma? (
app-crypt/gnupg
)
mysql? (
|| (
dev-lang/php[mysql]
dev-lang/php[mysqli]
)
)
spell? ( dev-lang/php[curl,spell] )
"

S="${WORKDIR}/${MY_P}"

src_install() {
webapp_src_preinst

dodoc CHANGELOG INSTALL README.md UPGRADING

insinto "${MY_HTDOCSDIR}"
doins -r [[:lower:]]* SQL
doins .htaccess

webapp_serverowned "${MY_HTDOCSDIR}"/logs
webapp_serverowned "${MY_HTDOCSDIR}"/temp

webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"

webapp_src_install
}

pkg_postinst() {
webapp_pkg_postinst

if [[ -n ${REPLACING_VERSIONS} ]]; then
elog "You can review the post-upgrade instructions at:"
elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
fi
}

0 comments on commit 37285d8

Please sign in to comment.