Skip to content

Commit

Permalink
dev-dotnet/gtk-sharp 2.12.21 (monolithic)
Browse files Browse the repository at this point in the history
  • Loading branch information
cnd committed Aug 13, 2015
1 parent 6618549 commit 3734280
Showing 1 changed file with 60 additions and 0 deletions.
60 changes: 60 additions & 0 deletions dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit dotnet autotools base

SLOT="2"
DESCRIPTION="gtk bindings for mono"
LICENSE="GPL-2"
HOMEPAGE="http://www.mono-project.com/GtkSharp"
KEYWORDS="~amd64 ~x86 ~ppc"
SRC_URI="http://download.mono-project.com/sources/gtk-sharp212/${P}.tar.gz"
IUSE="debug"

RESTRICT="test"

RDEPEND="
>=dev-lang/mono-3.0
x11-libs/pango
>=dev-libs/glib-2.31
dev-libs/atk
x11-libs/gtk+:2
gnome-base/libglade
dev-perl/XML-LibXML
!dev-dotnet/gtk-sharp-gapi
!dev-dotnet/gtk-sharp-docs
!dev-dotnet/gtk-dotnet-sharp
!dev-dotnet/gdk-sharp
!dev-dotnet/glib-sharp
!dev-dotnet/glade-sharp
!dev-dotnet/pango-sharp
!dev-dotnet/atk-sharp"
DEPEND="${RDEPEND}
virtual/pkgconfig
sys-devel/automake:1.11"

src_prepare() {
base_src_prepare
eautoreconf
libtoolize
}

src_configure() {
econf --disable-static \
--disable-dependency-tracking \
--disable-maintainer-mode \
$(use_enable debug)
}

src_compile() {
emake
}

src_install() {
default
dotnet_multilib_comply
sed -i "s/\\r//g" "${D}"/usr/bin/* || die "sed failed"
}

0 comments on commit 3734280

Please sign in to comment.