forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-backup/duplicity: version bump to 0.7.13.1
- Loading branch information
Showing
2 changed files
with
52 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST duplicity-0.7.10.tar.gz 1543523 SHA256 485fef15526d163c061e00ec08de216cf7d652e67d41de5dc3bed9fb42214842 SHA512 d04273384749c88d0a4f46bc1dcdcbb945ec1a78fb21064f12f0ca6c92cc73ad36fc3149461dbe0a660cd752a1147b2fa5d2b4056a5414c7790747eb5983e0bd WHIRLPOOL 1532b1e5ffc764951155ce248662d3ebf23fff71c538270ee1b2d37c7ad0a90705361b34418a323dfb4947ede42cd356e0daba18e4124e7342e5baadc5d0af22 | ||
DIST duplicity-0.7.11.tar.gz 1550197 SHA256 b047a1590a1f5bb3974643ad2cc9dfdd32f61adbf2c1989191fb12cb59c2ec07 SHA512 81ccb868625b261356b9cb2439659eb7574343c0a15ea7db099746216689a881d9a37b05711c232103ae0e7660b5cdc7dff6475eda81ecbdcfc28bced0eabe75 WHIRLPOOL 1c106933fe4e9ba535a7923e93474457f2ede8979c2f9ed400fb7a819872c05ec2adfd08920d7b81b3e97feb90844f141721fc5ff184e97ec0b3df9da1d311df | ||
DIST duplicity-0.7.12.tar.gz 1552442 SHA256 11cbad44a90891af1bf9e294260ba7c21a1660ccd3ab2c6e736ba74ac5cf0fe6 SHA512 8a532e7bb548c170184666a0ba2b41a15f3002c14edd64b1b1eb4df862647fc6dfde797d6ecf38e326d7c160c31ff521baf351e520835495e1d0e2ddbdb19f0f WHIRLPOOL 872d0b52a0f73507849d585fd5888d4754d5711ab5cc48d72b571cfb14fd1278093022f52238facf608c8b26aa0149f2e614a4819c85aeb9ee94305e81824147 | ||
DIST duplicity-0.7.13.1.tar.gz 1553736 SHA256 adb8668fb10e0b0f91cb77f758d02c02bf5c02e6c4835904a82cbdab6db4bef2 SHA512 08672910e61a089086992a1106ffc1e161ae3173514d35ae854eac719a095e48efaf7e298c1329ba3b439c0e97236644e88c615a013bd0e8ea9d956b38346ca6 WHIRLPOOL 2a9fddd1c41cadaa713c83805bce5d3e2de01540de29a47c7d545236e9e713b2004abfbae9977a115727db5fc661904f679cae7d0c9fb01ece04bdce212fb08c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit distutils-r1 versionator | ||
|
||
DESCRIPTION="Secure backup system using gnupg to encrypt data" | ||
HOMEPAGE="http://www.nongnu.org/duplicity/" | ||
SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos" | ||
IUSE="s3 test" | ||
|
||
CDEPEND=" | ||
net-libs/librsync | ||
app-crypt/gnupg | ||
dev-python/fasteners[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${CDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/pexpect[${PYTHON_USEDEP}] | ||
) | ||
" | ||
RDEPEND="${CDEPEND} | ||
dev-python/paramiko[${PYTHON_USEDEP}] | ||
s3? ( dev-python/boto[${PYTHON_USEDEP}] ) | ||
" | ||
|
||
python_prepare_all() { | ||
# workaround until failing test is fixed | ||
local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch ) | ||
|
||
distutils-r1_python_prepare_all | ||
|
||
sed -i "s/'COPYING',//" setup.py || die | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
pkg_postinst() { | ||
einfo "Duplicity has many optional dependencies to support various backends." | ||
einfo "Currently it's up to you to install them as necessary." | ||
} |