forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/buildbot-grid-view: Version bump to 2.10.1
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <[email protected]>
- Loading branch information
Showing
2 changed files
with
38 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST buildbot-grid-view-2.10.0.tar.gz 13685 BLAKE2B 56c871b24c48ce6723e8fba803f82b1c751b7a3ca61b8d7ec8adc50aa87f9d64d04ff6551b0a99535c04cbaf9b18763cf6469eadbd115d2f20c060cb97a3a27c SHA512 4e5099922e3e08f18a77aede09b25ee60ee629c7c94d76149164d3e1e4ea1cdb0bd1cb6689bad060c55f55f9a3527d3f49e9a99b963479e39c076e62c5ade085 | ||
DIST buildbot-grid-view-2.10.1.tar.gz 13697 BLAKE2B 1fa5f213fff4190773328c946b8e4aac0c5118fb2ee7d7ebcca41656abda98e89b4061f959d3378d1f05fd0c0f4f14e9b37980e204818b99b0b6a4b48ac56fc3 SHA512 14c60642c5fc9924d1670c9faa27288c58763c06a7eea580851e0853b25e272f371fedd8016cba9c5e04c51206781359c08e99664fcc6e9006191deb3bcf862f | ||
DIST buildbot-grid-view-2.8.2.tar.gz 13373 BLAKE2B 0a7a73011655e9a57574575943a3560c395ca4358c0f2169def8413a60f8381644512a227b54f016b23e6dcd18641d1ea7a3295f6c0a983c6f3caa9ab1dda60d SHA512 9b136d96f5a38f0d28f6c37db6269e039eca0cff5bbc7d75d43346566ba2e9f7924e453098f4777792429a7a9bbbb5e02c34a9b81e131d40dc3e339f4dd377f1 | ||
DIST buildbot-grid-view-2.8.4.tar.gz 13510 BLAKE2B 97816ae90c06cbc3ac63920da4dd2e1152750181a5c23c59d3f227f46131228140e676328aa80741626ff071679dd8c9385f3895ce92d27ce6d0264afe299872 SHA512 dfeb454f9d9162e30e0ea8555a0978ecfad2266e1a9412e0633924ad44ae404144ae4a51b58fdca31fa54b67fe53bab57cac1f54926fee346decf90623f91f89 |
37 changes: 37 additions & 0 deletions
37
dev-util/buildbot-grid-view/buildbot-grid-view-2.10.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="7" | ||
PYTHON_REQ_USE="sqlite" | ||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
|
||
DISTUTILS_USE_SETUPTOOLS="bdepend" | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="BuildBot grid view web interface" | ||
HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-grid-view/" | ||
|
||
MY_PV="${PV/_p/.post}" | ||
MY_P="${PN}-${MY_PV}" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
KEYWORDS="~amd64" | ||
|
||
IUSE="" | ||
|
||
RDEPEND="" | ||
|
||
DEPEND="${RDEPEND} | ||
~dev-util/buildbot-${PV}[${PYTHON_USEDEP}] | ||
~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}] | ||
" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
} |