Skip to content

Commit

Permalink
app-emulation/runc: version bump
Browse files Browse the repository at this point in the history
bump to latest upstream release.

Signed-off-by: Doug Goldstein <[email protected]>
  • Loading branch information
cardoe committed Dec 7, 2015
1 parent e7ff2dd commit 37c1ec7
Showing 1 changed file with 52 additions and 0 deletions.
52 changes: 52 additions & 0 deletions app-emulation/runc/runc-0.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils multilib

DESCRIPTION="runc container cli tools"
HOMEPAGE="http://runc.io"

GITHUB_URI="github.com/opencontainers/runc"

if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://${GITHUB_URI}.git"
inherit git-r3
else
SRC_URI="https://${GITHUB_URI}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="Apache-2.0"
SLOT="0"
IUSE="+seccomp"

DEPEND=">=dev-lang/go-1.4:="
RDEPEND="seccomp? ( sys-libs/libseccomp )"

src_prepare() {
epatch_user
}

src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"

# Setup GOPATH so things build
rm -rf .gopath
mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
export GOPATH="${PWD}/.gopath:${PWD}/vendor"

# build up optional flags
local options=( $(usex seccomp "seccomp") )

emake BUILDTAGS="${options[@]}"
}

src_install() {
dobin runc
}

0 comments on commit 37c1ec7

Please sign in to comment.