forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/glibmm: version bump 2.52.0 → 2.52.1, fix a memory leak in gio
Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
67 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glibmm-2.50.1.tar.xz 6444576 BLAKE2B dbbdb79d8de9510f9bec770523ca7f4c93d287cbd9890b2fbc08712f6a2815186ee792f6339820a14aa9e4d49c9d1735c6c6651994cc4e03549f0d96b33f87ad SHA512 4f25c75c1628ca2f4db1c29cebc63187d372603066b06aa6a66c6da792f9e02cb4a413e41f058a81e2d5a2b38d625de13df76115b278f010ce2fc493fe6e6bbb | ||
DIST glibmm-2.50.1.tar.xz 6444576 BLAKE2B dbbdb79d8de9510f9bec770523ca7f4c93d287cbd9890b2fbc08712f6a2815186ee792f6339820a14aa9e4d49c9d1735c6c6651994cc4e03549f0d96b33f87ad SHA256 1fd85051da9cb402cc8348cec72dfe4d79f9345df4a1dbf68703a4ded45846a4 SHA512 4f25c75c1628ca2f4db1c29cebc63187d372603066b06aa6a66c6da792f9e02cb4a413e41f058a81e2d5a2b38d625de13df76115b278f010ce2fc493fe6e6bbb WHIRLPOOL 54b656e04550a050994061db1498a3ac066b1e37643faa218ec1ef04604c0d37c799572b546e79c29f1b35586b1a5b0c354eca72151756eb99f4434a27fa7ae2 | ||
DIST glibmm-2.52.0.tar.xz 6450592 BLAKE2B 2ea123bd193c7a745f52b2357c620fdaaef34c6e349100e732c8a1efde921db6bb0c97de3a61e0e300b98a04eb1c218f1b216c01d36e62d60ea9897a075826ec SHA512 45cbbe4ce4ba04dcadbcc3b46159dda194235c10a7287075724b0e1c19db2e4db061dc2a66823205f6884b30e2ef87ceafdf9cc2970212a2424535dbe3b9a262 | ||
DIST glibmm-2.52.1.tar.xz 6451164 SHA256 dc19d20fb6b24d6b6da7cbe1b2190b38ae6ad64e6b93fecdcce71b995f43c975 SHA512 702158762cb28972b315ab98dc00a62e532bda08b6e76dc2a2556e8cb381c2021290891887a4af2fbff5a62bab4d50581be73037dc8e0dc47d5febd6cbeb7bda WHIRLPOOL e82abfc28bd7dd46b0d756033d4aa9f1343d19c028be3c489e647418d382ce331bf86dbf5752e0924efff9f96620a98b60ad8cf75dd3db0e55e02f29aa80fc97 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit gnome2 multilib-minimal | ||
|
||
DESCRIPTION="C++ interface for glib2" | ||
HOMEPAGE="https://www.gtkmm.org" | ||
|
||
LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system | ||
SLOT="2" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris" | ||
IUSE="doc debug test" | ||
|
||
RDEPEND=" | ||
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}] | ||
>=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen ) | ||
" | ||
# dev-cpp/mm-common needed for eautoreconf | ||
|
||
src_prepare() { | ||
if ! use test; then | ||
# don't waste time building tests | ||
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \ | ||
-i Makefile.am Makefile.in || die "sed 1 failed" | ||
fi | ||
|
||
# don't build examples - we want to install example sources, not binaries | ||
sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \ | ||
-i Makefile.am Makefile.in || die "sed 2 failed" | ||
|
||
gnome2_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" gnome2_src_configure \ | ||
$(use_enable debug debug-refcounting) \ | ||
$(multilib_native_use_enable doc documentation) \ | ||
--enable-deprecated-api | ||
} | ||
|
||
multilib_src_test() { | ||
cd tests | ||
default | ||
|
||
for i in */test; do | ||
${i} || die "Running tests failed at ${i}" | ||
done | ||
} | ||
|
||
multilib_src_install() { | ||
gnome2_src_install | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
|
||
find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null | ||
find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null | ||
dodoc -r examples | ||
} |