forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extension-gsconnect: Version bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
62 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gnome-shell-extension-gsconnect-12.tar.gz 1034122 BLAKE2B dc9e4003532bbb500c81d2bd0d2a715f60bb5c70b6bcf3286ebd8b2219d511f51e63c93ef30b0b71ced720531c811462f3b343d9a9eaa07ef4a56a498e5c497f SHA512 3b88aa7ff6e55556a6e438376c578a007d41d266dc91f6d56dfccde217bd0ede7ed40c10b05903582d9bde392f0a375f34b1fbdfd1aae0204f46b9d7e6c246ef | ||
DIST gnome-shell-extension-gsconnect-20.tar.gz 282464 BLAKE2B 1d0949a34f209f85ebe857494ef94ca429755c13d4988f5ef965f90194b7fad2d37ba0ebfb65ddb2df0db8aba17f27ca400e19755e528cf445dc1cd2b5a8b9d5 SHA512 7db21a580593f429eb7d89054d6ec5e867d33ddc36e29a7e08ba54be8941cc507f081539fdbb0b14bd9ef3c6461964f02e23c12136f475c683c90685e4ea1354 | ||
DIST gnome-shell-extension-gsconnect-21.tar.gz 290699 BLAKE2B cfdaf5d3e02e7a73009ff6f355f9ba444a811fa0834f1d16ac191217a613b56ab39d0952fdd1119e2e6371ba3e5ac89473d1a10de922189c6b2a40e0518b97fc SHA512 3382b5043fcaa359cb12777098f4f89ccdca1a20c6e0b953a8f165563902e3b4d0d469f09a59d01bad708748969efd79651cdd5ab9129c29ff656c6a918e0821 |
61 changes: 61 additions & 0 deletions
61
gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-21.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome2-utils meson readme.gentoo-r1 | ||
|
||
DESCRIPTION="KDE Connect implementation for Gnome Shell" | ||
HOMEPAGE="https://github.com/andyholmes/gnome-shell-extension-gsconnect" | ||
SRC_URI="https://github.com/andyholmes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="nautilus" | ||
|
||
COMMON_DEPEND="dev-libs/glib:2" | ||
|
||
RDEPEND="${COMMON_DEPEND} | ||
app-eselect/eselect-gnome-shell-extensions | ||
>=dev-libs/gjs-1.48 | ||
>=gnome-base/gnome-shell-3.28 | ||
gnome-base/gvfs | ||
|| ( ( net-libs/gnome-online-accounts dev-libs/libgdata ) dev-libs/folks ) | ||
|| ( media-libs/libcanberra media-libs/gsound ) | ||
nautilus? ( | ||
dev-python/nautilus-python | ||
gnome-base/nautilus[introspection] ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
virtual/pkgconfig | ||
" | ||
|
||
DISABLE_AUTOFORMATTING="yes" | ||
DOC_CONTENTS="For knowing more about how to do the setup, please visit: | ||
https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki/Installation" | ||
|
||
src_configure() { | ||
meson_src_configure \ | ||
$(meson_use nautilus) | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_schemas_update | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
readme.gentoo_print_elog | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_schemas_update | ||
} |