Skip to content

Commit

Permalink
app-emulation/lxd: add version 0.18
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
Alex Brandt committed Oct 11, 2015
1 parent 4499f9b commit 3895236
Show file tree
Hide file tree
Showing 7 changed files with 259 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/lxd/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST lxd-0.13.tar.bz2 3336161 SHA256 4228979ea9a856647f75f0230f58cc577c111a287f148787af766ab36c55f756 SHA512 12cd865ef63702674342df23ebb298b6ba39f0d44e9bfe91c643820be06ff30910145388a4daa2d63fbcb53c236e3cd4eb84e3e0bc617c85247322b0024c4920 WHIRLPOOL 82e788e9b35429df308d498955bd0cab06eb7d1a09c0a20bddad78490900b2cb78a44da9970db149ebfda546250a1d5aa2204e5f6f98b81a228310bfee3003a7
DIST lxd-0.14.tar.bz2 2526939 SHA256 c0c51ac5b3d30c7906323eba965011073b412a3c354ce095e46f14df4298c46c SHA512 d3f9eb38cdf71add270c895c1583dab85b0e0dba0d956900628b519881b41582113d6c25d37b9522493de069ad6a43b197ae895aefeb83391337273a4b60953e WHIRLPOOL 2b9c6931b81df7e60b13e35bfcd5272a46fb29377e11f6326616f55bf6c583db7be82d41273369518e9b9e434bee3b30f989b6816cd8dbdd40cc2cc1effac7b4
DIST lxd-0.16.tar.bz2 2660683 SHA256 bbe2b7542af34c93c7509e9638016a420bfc1daf1f1f45a33fa3d379ae10f14f SHA512 856e5ea1920ec3025cbd308a8e2ef656393a149111a38188f749e7d42a41032d762009d85316815c3f18ac0907fa9380758ca48666b13e900c9bbdf809d57f1c WHIRLPOOL f4bbea69073f2cc0dce65e39d88cdf1a0fadd4629b5b42bdee7ab385df459f78a2e36619c40ace687be124fb8d59c0da043cb1a8195630b2d0a051ab53297b89
DIST lxd-0.18.tar.bz2 2674919 SHA256 cb9c4823fb19ccef4827ee4dc3a105b60d3549b5023f4517d1471487469ea395 SHA512 5bbaae6eef27a0b14f8fee41d113afeea61de5414e5f7ed5011819eb6823a11dff647ac3f9781357304f7c5b04c618d05e4a04197cae6c6e4845cad5476d22ff WHIRLPOOL ca73e587f19491d79b03af2d205ab9f234b5acb1ff1f2d68a05be053cbd1ec89f6b9bc0fc64113980d7f2d6e3c7ece01d7d0c431c08a87b2b0ec555c6ff97914
18 changes: 18 additions & 0 deletions app-emulation/lxd/files/lxd-0.18-dont-go-get.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
--- Makefile.orig 2015-09-17 20:37:16.481867339 -0500
+++ Makefile 2015-09-17 20:53:27.715800926 -0500
@@ -12,15 +12,11 @@

.PHONY: default
default:
- -go get -t -v -d ./...
- -go get -t -v -d ./...
go install -v ./...
@echo "LXD built succesfuly"

.PHONY: client
client:
- -go get -t -v -d ./...
- -go get -t -v -d ./...
go install -v ./lxc
@echo "LXD client built succesfuly"

11 changes: 11 additions & 0 deletions app-emulation/lxd/files/lxd-0.18-nc-binary-name.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- lxd/rsync.go.orig 2015-09-17 21:00:29.290772099 -0500
+++ lxd/rsync.go 2015-09-17 21:00:54.737770359 -0500
@@ -73,7 +73,7 @@
* command (i.e. the command to run on --server). However, we're
* hardcoding that at the other end, so we can just ignore it.
*/
- rsyncCmd := fmt.Sprintf("sh -c \"nc -U %s\"", f.Name())
+ rsyncCmd := fmt.Sprintf("sh -c \"nc.openbsd -U %s\"", f.Name())
cmd := exec.Command("rsync", "-arvP", "--devices", "--partial", path, "localhost:/tmp/foo", "-e", rsyncCmd)
if err := cmd.Start(); err != nil {
return nil, nil, err
27 changes: 27 additions & 0 deletions app-emulation/lxd/files/lxd-0.18.confd
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Group which owns the shared socket
LXD_OPTIONS+=" --group lxd"



# Enable cpu profiling into the specified file
#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"

# Enable memory profiling into the specified file
#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"



# Enables debug mode
#LXD_OPTIONS+=" --debug"

# For debugging, print a complete stack trace every n seconds
#LXD_OPTIONS+=" --print-goroutines-every 5"

# Enables verbose mode
#LXD_OPTIONS+=" -v"

# Logfile to log to
#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"

# Enables syslog logging
#LXD_OPTIONS+=" --syslog"
32 changes: 32 additions & 0 deletions app-emulation/lxd/files/lxd-0.18.initd
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
#!/sbin/runscript
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

DAEMON=/usr/sbin/lxd
PIDFILE=/run/lxd.pid

depend() {
need cgmanager
need net
}

start() {
ebegin "Starting lxd server"

start-stop-daemon --start \
--pidfile ${PIDFILE} \
--exec ${DAEMON} \
--background \
--make-pidfile \
-- \
${LXD_OPTIONS}

eend $?
}

stop() {
ebegin "Stopping lxd server"
start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
eend $?
}
166 changes: 166 additions & 0 deletions app-emulation/lxd/lxd-0.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,166 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

DESCRIPTION="Fast, dense and secure container management"
HOMEPAGE="https://linuxcontainers.org/lxd/introduction/"
EGO_PN_PARENT="github.com/lxc"
EGO_PN="${EGO_PN_PARENT}/lxd"
SRC_URI="http://961db08fe45d5f5dd062-b8a7a040508aea6d369676e49b80719d.r29.cf2.rackcdn.com/${P}.tar.bz2"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

PLOCALES="de fr ja"
IUSE="btrfs +criu +daemon lvm nls test"

# IUSE and PLOCALES must be defined before l10n inherited
inherit bash-completion-r1 eutils golang-build l10n systemd user vcs-snapshot

DEPEND="
dev-go/go-crypto
>=dev-lang/go-1.4.2:=
dev-libs/protobuf
dev-vcs/git
nls? ( sys-devel/gettext )
test? (
app-misc/jq
dev-db/sqlite
net-misc/curl
sys-devel/gettext
)
"

RDEPEND="
daemon? (
app-admin/cgmanager
app-arch/xz-utils
app-emulation/lxc[cgmanager,seccomp]
net-analyzer/openbsd-netcat
net-misc/bridge-utils
net-misc/rsync[xattr]
sys-apps/iproute2
virtual/acl
btrfs? (
sys-fs/btrfs-progs
)
criu? (
sys-process/criu
)
lvm? (
sys-fs/lvm2
)
)
"

# KNOWN ISSUES:
# - Translations may not work. I've been unsuccessful in forcing
# localized output. Anyway, upstream (Canonical) doesn't install the
# message files.

# TODO:
# - since 0.15 gccgo is a supported compiler ('make gccgo'). It would
# be preferable for that support to go into the golang-build eclass not
# this package directly.
# - Add apparmor USE. There are some exec calls to apparmor_parser
# - Test build with Go 1.4 & 1.5
# - integrate "lxd shutdown" into initscript as custom action (default "stop"
# action should _not_ stop containers amirite?)
# "Perform a clean shutdown of LXD and all running containers"

src_prepare() {
cd "${S}/src/${EGO_PN}"

epatch "${FILESDIR}/${P}-dont-go-get.patch"

# Upstream requires the openbsd flavor of netcat (with -U), but
# Gentoo installs that with a renamed binary
epatch "${FILESDIR}/${P}-nc-binary-name.patch"

# Warn on unhandled locale changes
l10n_find_plocales_changes po "" .po
}

src_compile() {
golang-build_src_compile

cd "${S}/src/${EGO_PN}"

if use daemon; then
# Build binaries
GOPATH="${S}:$(get_golibdir_gopath)" emake
else
# build client tool
GOPATH="${S}:$(get_golibdir_gopath)" emake client
fi

use nls && emake build-mo
}

src_test() {
if use daemon; then
# Go native tests should succeed
golang-build_src_test
fi
}

src_install() {
# Installs all src,pkg to /usr/lib/go-gentoo
golang-build_src_install

cd "${S}"
dobin bin/lxc
if use daemon; then
dobin bin/fuidshift

dosbin bin/lxd
fi

cd "src/${EGO_PN}"

if use nls; then
for lingua in ${PLOCALES}; do
if use linguas_${lingua}; then
domo po/${lingua}.mo
fi
done
fi

if use daemon; then
newinitd "${FILESDIR}"/${P}.initd lxd
newconfd "${FILESDIR}"/${P}.confd lxd

systemd_dounit "${FILESDIR}"/lxd.service
fi

newbashcomp config/bash/lxc.in lxc

dodoc AUTHORS CONTRIBUTING.md README.md

docinto specs
dodoc specs/*
}

pkg_postinst() {
einfo
einfo "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
einfo "including a Quick Start."

# The messaging below only applies to daemon installs
use daemon || return 0

# The control socket will be owned by (and writeable by) this group.
enewgroup lxd

# Ubuntu also defines an lxd user but it appears unused (the daemon
# must run as root)

if test -n "${REPLACING_VERSIONS}"; then
einfo
einfo "If you are upgrading from version 0.14 or older, note that the --tcp"
einfo "is no longer available in /etc/conf.d/lxd. Instead, configure the"
einfo "listen address/port by setting the core.https_address server option."
fi
}
4 changes: 4 additions & 0 deletions app-emulation/lxd/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -19,6 +19,10 @@
<remote-id type="github">lxc/lxd</remote-id>
</upstream>
<use>
<flag name="btrfs">
Add support for managing instance/snapshot
disk using btrfs subvolumes
</flag>
<flag name="criu">
Add support for live-migrateable containers
</flag>
Expand Down

0 comments on commit 3895236

Please sign in to comment.