Skip to content

Commit

Permalink
sys-process/numactl: Bump to version 2.0.11
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 14, 2015
1 parent 9b2f4c6 commit 38c3825
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-process/numactl/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST numactl-2.0.10.tar.gz 98999 SHA256 9d197fefac81c73dc2b2e554f1758b2ec56d4e9b2f04a7f45dff5d6cb14fb9ce SHA512 3a82b28bbc724a2340950ac33396055da852ee06e5b1d3414cd83dd6f9e26fbb648faae35ce4009c76d6a180f3067a8f3fb18e3ffaa6b6db68adfc0877e94975 WHIRLPOOL 59a172c14d96b01b1e13d2913f6f820d4f9bacb2f80e2920d4350273ff01ab57d56ab4a163fde2df3898c4b7cf204bd4a333c99f9feb9d5bcd89fea799a3d2db
DIST numactl-2.0.11.tar.gz 408175 SHA256 450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861 SHA512 1969d7ee0ff3de0d6f1fa42ec089a17cdb3f92cb35d453b8f8b2eec49724c43787ecbd213357013a8f2500a260b0df9844d515815ca3a0376314a0eed050a0d4 WHIRLPOOL 2d22a54de00bea80835e206704652d4fead1b585b3bedd4eeb4b61d96514117e91a9c8bda466bd7f8d17e3777c4e7a8d69dd0a6e5b6ab29c0141e086c09c311b
DIST numactl-2.0.9.tar.gz 341455 SHA256 9ca033e6c14c0f26c20379b0cf9299429fd5a354a79c3c7880fd41ef69f7751c SHA512 483cbb1607da0f3bf0923202ea565100ea430b19502bdbd322f043f75dc945cc0f47878c0ed28badab23561c37da0b04aa12d07656bb4666c4f8d02a0d256407 WHIRLPOOL 5aba5b4a6ab0a4f06a2266054fdc7be8ca81696cf417e4fa4d10667ab95195edc5e002551a3bda4ea1eb25caf01d171ed18a16e4c29960902546aa78d7b93d73
54 changes: 54 additions & 0 deletions sys-process/numactl/numactl-2.0.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit autotools eutils toolchain-funcs multilib-minimal

DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
# ARM lacks the __NR_migrate_pages syscall.
KEYWORDS="~amd64 -arm ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
IUSE=""

ECONF_SOURCE=${S}

src_prepare() {
epatch "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
epatch "${FILESDIR}"/${PN}-2.0.10-numademo-cflags.patch #540856
eautoreconf
# We need to copy the sources or else tests will fail
multilib_copy_sources
}

multilib_src_test() {
if multilib_is_native_abi ; then
if [ -d /sys/devices/system/node ]; then
einfo "The only generically safe test is regress2."
einfo "The other test cases require 2 NUMA nodes."
emake regress2
else
ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
fi
fi
}

multilib_src_compile() {
multilib_is_native_abi && default || emake libnuma.la
}

multilib_src_install() {
emake DESTDIR="${D}" install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
}

multilib_src_install_all() {
DOCS=( README TODO CHANGES DESIGN )
einstalldocs
# delete man pages provided by the man-pages package #238805
rm -r "${ED}"/usr/share/man/man[25] || die
}

0 comments on commit 38c3825

Please sign in to comment.