Skip to content

Commit

Permalink
app-admin/tripwire: Bumps version to 2.4.3.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
Chema Alonso Josa committed Feb 2, 2017
1 parent 34c7a2e commit 38d3cdc
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/tripwire/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tripwire-2.4.2.2-src.tar.bz2 716616 SHA256 e09a7bdca9302e704cc62067399e0b584488f825b0e58c82ad6d54cd2e899fad SHA512 be39757aac7b74d4deac6c5048d0964d839a32f8f2a0d1878c4246888c4d59e35a503413595178c7af3a0da80725d0b36c21026dc734e1f760c9affda017bbbb WHIRLPOOL beb99e1ae055947a4b94a45f51492bcc453def5a41188f853ff3285a85ef8e2921274b86b095b77dbcdc8f549358f6216996a75ba391247e17bf7a29c78849c5
DIST tripwire-2.4.3.1.tar.gz 932665 SHA256 9744af4de7ecb1d643442eb22f08c819556494bb6f56f5879e22c3438f2db896 SHA512 fb5f0ad353da826a0e8381e534e0da1ac9335851e108a23053e378afd3aec6e66931446addbf0ba8d55eaa8d3148c471056e26095aeff7696ed9b6d3633cdf90 WHIRLPOOL b87447869d845be840399389a3e3ed5f9c961f6777c1b463755994876b191e08cca359273826466d34f2f32a26b597f23d130f6cb689224ed3ff58810efceed1
DIST tripwire-2.4.3.2.tar.gz 967679 SHA256 25588c585f1af60958b3dce5bfc28e52c3237b2690dd5f4120e9c2f42d98fd2b SHA512 f3a3d5f12178d0766356d6280b3d993c29c1091357402661f0a4bb7676c640a147b74050c64e910c1210adef11903bde463813446e2c0ee9a34038876928bdfd WHIRLPOOL ac9812f3ec41afed5951e871d0ddad64eef3514a4cae071f414c7fa10d7318393d26107bb7007ca61554c328206b0da4790f0bc400fa7ea2159eb0b4f35e8303
79 changes: 79 additions & 0 deletions app-admin/tripwire/tripwire-2.4.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils flag-o-matic

DESCRIPTION="Open Source File Integrity Checker and IDS"
HOMEPAGE="http://www.tripwire.org/"
SRC_URI="https://github.com/Tripwire/tripwire-open-source/archive/${PV}.tar.gz -> ${PF}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="libressl ssl static +tools"

DEPEND="sys-devel/automake
sys-devel/autoconf
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)"
RDEPEND="virtual/cron
virtual/mta
ssl? ( dev-libs/openssl )"
PDEPEND="tools? ( app-admin/mktwpol )"

S="${WORKDIR}/tripwire-open-source-${PV}"

src_prepare() {
default
eautoreconf
}

src_configure() {
# tripwire can be sensitive to compiler optimisation.
# see #32613, #45823, and others.
# [email protected]
strip-flags
append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
econf $(use_enable ssl openssl) $(use_enable static)
}

src_install() {
dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
dodir /etc/tripwire /var/lib/tripwire{,/report}
keepdir /var/lib/tripwire{,/report}

exeinto /etc/cron.daily
doexe "${FILESDIR}"/tripwire

dodoc ChangeLog policy/policyguide.txt TRADEMARK \
"${FILESDIR}"/tripwire.txt

insinto /etc/tripwire
doins "${FILESDIR}"/twcfg.txt policy/twpol-GENERIC.txt

fperms 750 /etc/cron.daily/tripwire
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Tripwire needs to be configured before its first run. You can"
elog "do this by manually editing the twpol-GENERIC.txt file shipped with"
elog "the package to suit your needs. A quickstart guide is provided"
elog "in tripwire.txt file to help you with this."
elog "To configure tripwire automatically, you can use the twsetup.sh"
elog "script provided by the app-admin/mktwpol package. This package is"
elog "installed for you by the \"tools\" USE flag (which is enabled by"
elog "default."
else
elog "Maintenance of tripwire policy files as packages are added"
elog "and deleted from your system can be automated by the mktwpol.sh"
elog "script provided by the app-admin/mktwpol package. This package"
elog "is installed for you if you append \"tools\" to your USE flags"
fi
}

0 comments on commit 38d3cdc

Please sign in to comment.