Skip to content

Commit

Permalink
sys-apps/dbus-broker: add 31
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/846494
Closes: gentoo#25530
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
floppym committed May 19, 2022
1 parent 6b6f5b4 commit 38da12b
Show file tree
Hide file tree
Showing 3 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/dbus-broker/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST c-stdaux-8652c488b8f1c29629a5179d4551d0a691ae5901.tar.gz 13075 BLAKE2B ef08
DIST c-utf8-0837214a9780b7d771a3b3ce9a49196ac0a9d52f.tar.gz 9340 BLAKE2B 4bfa39c39aa8db8b7d797d78081b5f3104c659e2ceefef65aa2d3c03ffb5889d772cb78328473e3557c943b2487b7bcb7b68d7dc7f2b95940b0448b3479f1b23 SHA512 2df368af5023fac6c7f2e018c0cbfd73225bf1c4e0d0387931352909323175652bcd3739e9e6b76a099aea5d3f0290198aa70c69ecc5e9ef22df214f8c75da79
DIST dbus-broker-29.tar.gz 216639 BLAKE2B 94c8b7ea01367eae176d9411af064a960a054d6fbeb2bdebe9ba983d0938443abeb521f32e0eb9ae28155d5c5ebcf461317223387ccfad624ddd24e6bc8e227b SHA512 4c31b8c15f5d1ada0eb9c63c905c9fc9b3b8336beb533974b9c2b2a6a89c306b77d029d1ddbccbad873f62cc0d02cc373a090907dd19eae1a8a7fc2e3a4c2113
DIST dbus-broker-30.tar.xz 238688 BLAKE2B 716bdeac726e0168e09a5893f1906888c0dc63e4c5f377f2d5ba100f1a07da17bb0379053ac079e7c55e7af09c3d382368dd317df52e04eb0fe96af03aba7441 SHA512 8b7f614e18d15baa558de2c77fc65526011e75f9592d06ddb3cafa211ec9a1c45aa42a0e32122cb16bdfce8bc34407241080f37891fe5ccb6c4577f1cd4bc66c
DIST dbus-broker-31.tar.xz 239520 BLAKE2B ba34308de7c598e72ac3874894fb90ebc6970840eb2fc193a2b3294033759b39d7d712695ddbc88c3b947842b0131e0a068ffe3cef616ce431d9a8c021f30593 SHA512 22fd53cff84e48ae1c11303b5340e16dc9b7124c9e562174c1f0af465c55d69bb8b2768063de281f6f791442126a29ab864ad6b8acf110247a500f6425eae5d9
57 changes: 57 additions & 0 deletions sys-apps/dbus-broker/dbus-broker-31.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 2017-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bus1/dbus-broker.git"
else
SRC_URI="https://github.com/bus1/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
fi

DESCRIPTION="Linux D-Bus Message Broker"
HOMEPAGE="https://github.com/bus1/dbus-broker/wiki"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="audit doc +launcher selinux"

DEPEND="
audit? (
>=sys-process/audit-3.0
>=sys-libs/libcap-ng-0.6
)
launcher? (
>=dev-libs/expat-2.2
>=sys-apps/systemd-230:0=
)
selinux? ( >=sys-libs/libselinux-3.2 )
"
RDEPEND="${DEPEND}
launcher? ( sys-apps/dbus )"
BDEPEND="
doc? ( dev-python/docutils )
virtual/pkgconfig
"

if [[ ${PV} == 9999 ]]; then
src_unpack() {
git-r3_src_unpack
cd "${P}" || die
meson subprojects download || die
}
fi

src_configure() {
local emesonargs=(
-Daudit=$(usex audit true false)
-Ddocs=$(usex doc true false)
-Dlauncher=$(usex launcher true false)
-Dselinux=$(usex selinux true false)
)
meson_src_configure
}
1 change: 1 addition & 0 deletions sys-apps/dbus-broker/dbus-broker-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -9,6 +9,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bus1/dbus-broker.git"
else
SRC_URI="https://github.com/bus1/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
fi

Expand Down

0 comments on commit 38da12b

Please sign in to comment.