forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/gentoolkit: Fix TypeError in setup.py with python3
Bug: https://bugs.gentoo.org/568906 Package-Manager: portage-2.2.26_p32
- Loading branch information
Showing
3 changed files
with
33 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
From 4e06e9f032ed187ce682434955778c3241854e26 Mon Sep 17 00:00:00 2001 | ||
From: Mike Gilbert <[email protected]> | ||
Date: Sun, 20 Dec 2015 15:19:06 -0500 | ||
Subject: [PATCH] Remove useless print() in set_version | ||
|
||
This was causing a TypeError in python3. | ||
|
||
Bug: https://bugs.gentoo.org/568906 | ||
--- | ||
setup.py | 3 --- | ||
1 file changed, 3 deletions(-) | ||
|
||
diff --git a/setup.py b/setup.py | ||
index b32b7d6..01e4b3e 100755 | ||
--- a/setup.py | ||
+++ b/setup.py | ||
@@ -80,9 +80,6 @@ class set_version(core.Command): | ||
with io.open(f[0], 'r', 1, 'utf_8') as s: | ||
for line in s: | ||
newline = re.sub(pattern %f[1], '"%s"' % ver, line, 1) | ||
- if newline != line: | ||
- #log.info("%s: %s" % (f, newline)) | ||
- print("%s: %s" % (f[0], newline.encode('utf_8').strip('\n'))) | ||
updated_file.append(newline) | ||
with io.open(f[0], 'w', 1, 'utf_8') as s: | ||
s.writelines(updated_file) | ||
-- | ||
2.6.4 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters