Skip to content

Commit

Permalink
media-libs/opus: Bump to version 1.3_rc2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
Lars Wendler committed Sep 24, 2018
1 parent 0761c62 commit 3901736
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/opus/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST opus-1.2.1.tar.gz 1011070 BLAKE2B eff3e20c22cd5370a6a3aabf90cfe6f950a3a8d33cbaed8e053ff637c3c45d1d007a10da2f7983564c0bfcc3768f79ffbc041489fc8835f1faaa2fb6c0ef3800 SHA512 4a98d0a7dbd1a313e89407576805fd733c1192e8ef7e1137e3260025478a1cf1c5a8b71b48c372a0cffe6340524137fe47f181651888284f8221fb4d673f7cd5
DIST opus-1.3-rc2.tar.gz 1033559 BLAKE2B 8149d7c23bc7db3a13649fa275d701d2236f7cbf603286248f2447611cadecf34b533cf743efc68b6b52793b3db668eefea54cbdd7946dd9188955a9ae3f7489 SHA512 95a3cf0d9c92320ff4d01376d171077e16e06dc97e6668b705d91dbd16d5e83d1cb6fd3d0f6945cc2767189a0ecb219c8be9013669d61f578149158d3eec2817
51 changes: 51 additions & 0 deletions media-libs/opus/opus-1.3_rc2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit multilib-minimal

MY_P="${P/_/-}"

if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.xiph.org/opus.git"
else
SRC_URI="https://archive.mozilla.org/pub/opus/${MY_P}.tar.gz"
if [[ "${PV}" != *_alpha* ]] && [[ "${PV}" != *_beta* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
fi

DESCRIPTION="Open codec designed for internet transmission of interactive speech and audio"
HOMEPAGE="https://opus-codec.org/"

LICENSE="BSD-2"
SLOT="0"
INTRINSIC_FLAGS="cpu_flags_x86_sse cpu_flags_arm_neon"
IUSE="custom-modes doc static-libs ${INTRINSIC_FLAGS}"

DEPEND="
doc? (
app-doc/doxygen
media-gfx/graphviz
)
"

S="${WORKDIR}/${MY_P}"

multilib_src_configure() {
local myeconfargs=(
$(use_enable custom-modes)
$(use_enable doc)
$(use_enable static-libs static)
)
for i in ${INTRINSIC_FLAGS} ; do
use ${i} && myeconfargs+=( --enable-intrinsics )
done
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_install_all() {
default
find "${ED}" -name "*.la" -delete || die
}

0 comments on commit 3901736

Please sign in to comment.