Skip to content

Commit

Permalink
games-misc/lolcat: allow newer optimist versions to work
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/911512
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Sep 8, 2023
1 parent a136b69 commit 391bca5
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions games-misc/lolcat/lolcat-100.0.1-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

USE_RUBY="ruby31 ruby32"

RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="lolcat.gemspec"

inherit ruby-fakegem

DESCRIPTION="Rainbows and unicorns!"
HOMEPAGE="https://github.com/busyloop/lolcat"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

ruby_add_rdepend "
dev-ruby/optimist:3
>=dev-ruby/paint-2.1:0"

all_ruby_prepare() {
sed -e '/manpages/ s:^:#:' \
-e 's/git ls-files --/echo/' \
-e 's/git ls-files/find/' \
-e '/optimist/ s/3.0.0/3.0/' \
-i ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_install() {
doman man/lolcat.6
ruby_fakegem_binwrapper lolcat
}

0 comments on commit 391bca5

Please sign in to comment.