forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/vala-common: version bump 0.34.9 → 0.34.16
Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
77 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST vala-0.34.16.tar.xz 2795676 BLAKE2B 64428099c209e13a6aad09233af650f412efa191ff4873fae1dbfb9bcc252e13d4e152733c9f199cd23323872fd912807a685980f651c1f784bfaffae7bf4162 SHA512 6411d55524a6c717c2eaf5cc1231ac931400e3f66d151a8b8856910258eb5bd7affe3a90946de34feb51aabfafce721b8d57f61e0475095b275d20b73cc4bbec | ||
DIST vala-0.34.9.tar.xz 2783952 BLAKE2B e90728075ac546e8abc125886182abd5fc357be5138bfea1ed058f41bf07968e55e032469cc068cefdb6a4d53f1c029ca7e728c57b00f6b9845e32c4410e8258 SHA512 8128dfbb50d0db2317feb4a358310de972ecb6f4dccaceb4d55cf3a024f4d83422e3137c92238e1a0a0b4766367ad307909a1310445017c71944ac30fc68d01f | ||
DIST vala-0.36.7.tar.xz 2854668 BLAKE2B 2fcb528b26a56ee9f9d362ec1891c873ee26580132c052554a3d021fea32c0cee6dc6e8c6419f88798f5066a70d54084757893b2d46e3b286b441a51a4169c92 SHA512 7a6daac5be72240ae998b2c26e240a8b6bbc44c8bb6a036357fc0419cd7b40e14ea76c8125eb49a8d252627425613512410ba7868eb579b13d299e2ff0f4082b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,76 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GNOME_ORG_MODULE="vala" | ||
|
||
inherit gnome.org | ||
|
||
DESCRIPTION="Build infrastructure for packages that use Vala" | ||
HOMEPAGE="https://wiki.gnome.org/Projects/Vala" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x64-solaris" | ||
IUSE="" | ||
|
||
# Previously ${PN} was part of dev-lang/vala | ||
RDEPEND=" | ||
!<dev-lang/vala-0.10.4-r2 | ||
!<dev-lang/vala-0.12.1-r1:0.12 | ||
!<dev-lang/vala-0.14.2-r2:0.14 | ||
!<dev-lang/vala-0.16.1-r2:0.16 | ||
!<dev-lang/vala-0.17.5:0.18 | ||
" | ||
DEPEND="" | ||
|
||
src_configure() { :; } | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
insinto /usr/share/aclocal | ||
doins vala.m4 vapigen/vapigen.m4 | ||
insinto /usr/share/vala | ||
doins vapigen/Makefile.vapigen | ||
} | ||
|
||
pkg_postinst() { | ||
# Hack to prevent alternatives_auto_makesym in previously installed | ||
# dev-lang/vala's pkg_postrm from overwriting vala-common's files | ||
if has_version '<dev-lang/vala-0.10.4-r2:0.10' && [[ -f "${EROOT}usr/share/aclocal/vala-0-10.m4" ]]; then | ||
ebegin "Removing old vala-0.10 macros" | ||
rm "${EROOT}usr/share/aclocal/vala-0-10.m4" &> /dev/null | ||
eend $? | ||
fi | ||
if has_version '<dev-lang/vala-0.12.1-r1:0.12' && [[ -f "${EROOT}usr/share/aclocal/vala-0-12.m4" ]]; then | ||
ebegin "Removing old vala-0.12 macros" | ||
rm "${EROOT}usr/share/aclocal/vala-0-12.m4" &> /dev/null | ||
eend $? | ||
fi | ||
if has_version '<dev-lang/vala-0.14.2-r2:0.14' && [[ -f "${EROOT}usr/share/aclocal/vala-0-14.m4" ]]; then | ||
ebegin "Removing old vala-0.14 macros" | ||
rm "${EROOT}usr/share/aclocal/vala-0-14.m4" &> /dev/null | ||
eend $? | ||
fi | ||
if has_version '<dev-lang/vala-0.16.1-r2:0.16' && [[ -f "${EROOT}usr/share/aclocal/vala-0-16.m4" ]]; then | ||
ebegin "Removing old vala-0.16 macros" | ||
rm "${EROOT}usr/share/aclocal/vala-0-14.m4" &> /dev/null | ||
eend $? | ||
if [[ -f "${EROOT}usr/share/vala-0.16/Makefile.vapigen" ]]; then | ||
ebegin "Removing old vala-0.16 makefile template" | ||
rm "${EROOT}usr/share/vala-0.16/Makefile.vapigen" &> /dev/null | ||
eend $? | ||
fi | ||
fi | ||
if has_version '<dev-lang/vala-0.17.5:0.18' && [[ -f "${EROOT}usr/share/aclocal/vala-0-18.m4" ]]; then | ||
ebegin "Removing old vala-0.18 macros" | ||
rm "${EROOT}usr/share/aclocal/vala-0-12.m4" &> /dev/null | ||
eend $? | ||
if [[ -f "${EROOT}usr/share/vala-0.18/Makefile.vapigen" ]]; then | ||
ebegin "Removing old vala-0.18 makefile template" | ||
rm "${EROOT}usr/share/vala-0.18/Makefile.vapigen" &> /dev/null | ||
eend $? | ||
fi | ||
fi | ||
} |