Skip to content

Commit

Permalink
sys-kernel/cryptodev: Version bump (bug #613224).
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Jeroen Roovers committed Apr 24, 2017
1 parent dea92ed commit 394807c
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/cryptodev/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cryptodev-linux-1.7.tar.gz 52827 SHA256 41880533b53de4d7b3f054e230f576988dafb8eed7bef5ebcf6422bb2e3a3b25 SHA512 b0073bc547782973587654cb14205ec624059ef46f88ed2b36236d37203f9231ffb8124489b1b2fea735eb7f89bd1011f0d1546eae7b6f562e26ec7a72a59b6c WHIRLPOOL fdc3588949264a575bce7d88286b30663b3ce7232340c5065b9c8cf8f3759c9e3844dc11499cb68c529dd23dcd865f778ecdc2b8535e75e97df270c26df2cd84
DIST cryptodev-linux-1.9.tar.gz 54409 SHA256 9f4c0b49b30e267d776f79455d09c70cc9c12c86eee400a0d0a0cd1d8e467950 SHA512 8aff822e834d7d77f2b954b3f6de22d7de9659dac27b8a185b7ca060ff4b17bd38e287bb5c19043a53f5015a3f000d31be961695152bad0fb9f55785b2753d29 WHIRLPOOL 575a6c7bac5cc5d0263493799ee9195b10d4f7d80136bf2838637e59bc9126ea197d36d3965b3ffe38e602fb775ac1d5f9b1d2aac264ad4b1cca751210d15c68
56 changes: 56 additions & 0 deletions sys-kernel/cryptodev/cryptodev-1.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit linux-info linux-mod

DESCRIPTION="device that allows access to Linux kernel cryptographic drivers"
HOMEPAGE="http://cryptodev-linux.org/index.html"
SRC_URI="http://download.gna.org/cryptodev-linux/${PN}-linux-${PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"

LICENSE="GPL-2+"
SLOT="0"
IUSE="examples"

DEPEND="virtual/linux-sources"
RDEPEND=""
#test do not compile
RESTRICT="test"
S=${WORKDIR}/${PN}-linux-${PV}

MODULE_NAMES="cryptodev(extra:${S})"

pkg_pretend() {
if use kernel_linux ; then
CONFIG_CHECK="~CRYPTO ~CRYPTO_BLKCIPHER ~CRYPTO_AEAD"
check_extra_config
fi
}

pkg_setup() {
if use kernel_linux ; then
linux-mod_pkg_setup
else
die "cryptodev ebuild only support linux"
fi
BUILD_TARGETS="build"
export KERNEL_DIR
}

src_prepare() {
default

# get_unused_fd was removed in 3.19
sed -i 's,get_unused_fd(),get_unused_fd_flags(0),' ioctl.c || die
}

src_install() {
linux-mod_src_install
if use examples ; then
docinto examples
dodoc example/*
fi
insinto /usr/include/crypto
doins crypto/cryptodev.h
}

0 comments on commit 394807c

Please sign in to comment.