Skip to content

Commit

Permalink
Merge remote-tracking branch 'remotes/Elizafox/master'
Browse files Browse the repository at this point in the history
Pull request: gentoo#447
  • Loading branch information
Ian Delaney committed Dec 8, 2015
2 parents 95c4777 + 0ebad56 commit 3994961
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/pkgconf/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pkgconf-0.9.11.tar.bz2 86489 SHA256 3bdae1b2672133943dc0dda694ed57074f8b03c3fea10efb215d76d3cabe2c3b SHA512 21313ef29afcaa7c49a8cb512ecd3a821693945c22fb1a670ada74f41bca320e1b9ffb64e79adc2c33cb86822b74ddc850fadb16ddcde7eb805b81a50096992f WHIRLPOOL 7442a456af7e959c86f318ee74ec89883cc4e2ad16c9708f98d8ab30cdcf71ea7ef13f7e0f9bf945717b1dea8a317ffc5322878f88a5084c2dcbdc2aeafaf4d2
DIST pkgconf-0.9.12.tar.bz2 87109 SHA256 7ec8b516e655e247f4ba976837cee808134785819ab8f538f652fe919cc6c09f SHA512 efe13db7a46992eb44ead493fc12b3fc6a5567e0206f701b6c48d9b5eb0bc90fcc9ae7a7e08ae641bb10df869287e5b68291701d4013d6cf27bd2b1518c29192 WHIRLPOOL 9fa7336e111f29648f5c37310bdeb2266bead1b86ff18183cfb57c06054916d235da20a5723bd364497d20a1f4db399eaf77f38c0bfc1519f2b7b825ab4666d0
58 changes: 58 additions & 0 deletions dev-util/pkgconf/pkgconf-0.9.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
inherit autotools git-2 multilib-minimal
else
inherit eutils multilib-minimal
SRC_URI="http://rabbit.dereferenced.org/~nenolod/distfiles/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi

DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"

LICENSE="BSD-1"
SLOT="0"
IUSE="+pkg-config strict"

RESTRICT="test" # at least until 0.9.13

DEPEND=""
RDEPEND="${DEPEND}
pkg-config? (
!dev-util/pkgconfig
!dev-util/pkg-config-lite
!dev-util/pkgconfig-openbsd[pkg-config]
)"

MULTILIB_CHOST_TOOLS=(
/usr/bin/pkgconf
)

src_prepare() {
[[ -e configure ]] || eautoreconf

if use pkg-config; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config
)
fi
}

multilib_src_configure() {
ECONF_SOURCE=${S} \
econf $(use_enable strict)
}

multilib_src_install() {
default
use pkg-config \
&& dosym pkgconf /usr/bin/pkg-config \
|| rm "${ED}"/usr/share/aclocal/pkg.m4 \
|| die
}

0 comments on commit 3994961

Please sign in to comment.