Skip to content

Commit

Permalink
kde-misc/kio-gdrive: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
kensington committed Oct 14, 2016
1 parent 9b893d2 commit 39e34c8
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-misc/kio-gdrive/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kio-gdrive-1.0.2.tar.xz 22512 SHA256 8cf250d84a97a7bdf97ae5c5cdfc06d38bbbae76266d79e436b48931d0dcecaa SHA512 de7df4caa17d2669a8d3390c2f876f037175c2e5a962256b84886a6177897433b832723828445068a37b524bf6795ee2bade4ca21f0e50e25ed631c4b37e8afe WHIRLPOOL f0d64dd5473c13e7ffb6833a4fc6717cbaaf1803d46d46c9b6e07b1db8677bd37ea4d400451b8d494ad917243fbd04786e86ce22dce9ba22f6505faadf61fd27
DIST kio-gdrive-1.0.3.tar.xz 22640 SHA256 2f7cc34d33f6d087b40f062d3d6784375833a4be228081f27edd20b0fdfda754 SHA512 28cb59cc981d648e4a82a1983a2a24146721fc1a6c224cf6c6f17039457cb5e0e95998a424ea7cae1cf8f865109e476e53f400761a6dc023c550bf3ce6b551c5 WHIRLPOOL 75d0d8e43a82c036333fc56b653840dad9145817d522e3016aac88c3bb5b1b316967837c4055903517e5139a7efa10fd5bd3f226859ab02af46502a751280534
51 changes: 51 additions & 0 deletions kde-misc/kio-gdrive/kio-gdrive-1.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

KDE_TEST="optional"
inherit kde5

DESCRIPTION="KIO Slave for Google Drive service"
HOMEPAGE="https://phabricator.kde.org/project/profile/72/"

if [[ ${KDE_BUILD_TYPE} != live ]] ; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
KEYWORDS="~amd64"
fi

IUSE="+dolphin"

DOCS=( README.md )

COMMON_DEPEND="
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_qt_dep qtwidgets)
dev-libs/qtkeychain:=[qt5]
>=net-libs/libkgapi-5.3.1:5
"
DEPEND="${COMMON_DEPEND}
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
"
RDEPEND="${COMMON_DEPEND}
dolphin? ( $(add_kdeapps_dep dolphin) )
"

src_configure() {
local mycmakeargs=(
-DDOLPHIN_INTEGRATION=$(usex dolphin)
)

kde5_src_configure
}

pkg_postinst() {
kde5_pkg_postinst
einfo
einfo "Either click on 'Google Drive File Manager' in the application"
einfo "launcher or type 'gdrive:/' in dolphin's location bar."
einfo
}

0 comments on commit 39e34c8

Please sign in to comment.