forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/tf: backport upstream patch to build with gcc6, bug #593938, …
…patch by Peter Levine Package-Manager: portage-2.3.2
- Loading branch information
Showing
2 changed files
with
24 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
commit b0d31cc1e9a43b45d216ee7f804e901a5c0f8936 | ||
Author: Hodorgasm <[email protected]> | ||
Date: Mon Sep 19 17:58:22 2016 -0400 | ||
|
||
Fix "stdlib.h: No such file or directory" errors in GCC-6 | ||
|
||
Including '-isystem /usr/include' breaks building with GCC-6. | ||
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129 | ||
|
||
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt | ||
index 8077561..cf72127 100644 | ||
--- a/tf/CMakeLists.txt | ||
+++ b/tf/CMakeLists.txt | ||
@@ -8,7 +8,7 @@ find_package(catkin COMPONENTS angles geometry_msgs message_filters message_gene | ||
|
||
catkin_python_setup() | ||
|
||
-include_directories(SYSTEM ${Boost_INCLUDE_DIR} | ||
+include_directories(${Boost_INCLUDE_DIR} | ||
${catkin_INCLUDE_DIRS} | ||
) | ||
include_directories(include) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters