Skip to content

Commit

Permalink
dev-ros/tf: backport upstream patch to build with gcc6, bug #593938, …
Browse files Browse the repository at this point in the history
…patch by Peter Levine

Package-Manager: portage-2.3.2
  • Loading branch information
aballier committed Oct 14, 2016
1 parent d4b5fc6 commit 39f0ec6
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 1 deletion.
22 changes: 22 additions & 0 deletions dev-ros/tf/files/gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
commit b0d31cc1e9a43b45d216ee7f804e901a5c0f8936
Author: Hodorgasm <[email protected]>
Date: Mon Sep 19 17:58:22 2016 -0400

Fix "stdlib.h: No such file or directory" errors in GCC-6

Including '-isystem /usr/include' breaks building with GCC-6.
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129

diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
index 8077561..cf72127 100644
--- a/tf/CMakeLists.txt
+++ b/tf/CMakeLists.txt
@@ -8,7 +8,7 @@ find_package(catkin COMPONENTS angles geometry_msgs message_filters message_gene

catkin_python_setup()

-include_directories(SYSTEM ${Boost_INCLUDE_DIR}
+include_directories(${Boost_INCLUDE_DIR}
${catkin_INCLUDE_DIRS}
)
include_directories(include)
3 changes: 2 additions & 1 deletion dev-ros/tf/tf-1.11.8.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -37,3 +37,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose[${PYTHON_USEDEP}]
)"
PATCHES=( "${FILESDIR}/gcc6.patch" )

0 comments on commit 39f0ec6

Please sign in to comment.