forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/pycharm-professional: Version bump (v2021.1.2)
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <[email protected]>
- Loading branch information
Showing
2 changed files
with
62 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
61 changes: 61 additions & 0 deletions
61
dev-util/pycharm-professional/pycharm-professional-2021.1.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit desktop gnome2-utils readme.gentoo-r1 xdg | ||
|
||
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis" | ||
HOMEPAGE="http://www.jetbrains.com/pycharm/" | ||
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz" | ||
|
||
LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview" | ||
SLOT="0" | ||
KEYWORDS="amd64 x86" | ||
IUSE="+bundled-jdk" | ||
|
||
RDEPEND="!bundled-jdk? ( >=virtual/jre-1.8 ) | ||
dev-libs/libdbusmenu | ||
dev-python/pip" | ||
|
||
RESTRICT="mirror strip" | ||
|
||
QA_PREBUILT="*" | ||
|
||
MY_PN=${PN/-professional/} | ||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
src_install() { | ||
insinto /opt/${PN} | ||
doins -r * | ||
|
||
if use bundled-jdk; then | ||
fperms -R a+x /opt/pycharm-professional/jbr/bin/ | ||
else | ||
rm -r "${D}"/opt/pycharm-professional/jbr/ || die | ||
fi | ||
|
||
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh} | ||
|
||
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN} | ||
newicon bin/${MY_PN}.png ${PN}.png | ||
make_desktop_entry ${PN} ${PN} ${PN} | ||
|
||
local rub | ||
|
||
for rub in aarch64 mips64el ppc64le; do | ||
rm -r "${D}"/opt/pycharm-professional/lib/pty4j-native/linux/${rub} || die | ||
done | ||
|
||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_icon_cache_update | ||
} |