Skip to content

Commit

Permalink
dev-python/django: Bump to 3.2.19
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 4, 2023
1 parent 9a0f22f commit 3a5885d
Show file tree
Hide file tree
Showing 3 changed files with 142 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/django/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,7 @@
DIST Django-3.2.18.checksum.txt 2563 BLAKE2B 8deb25cdc9f3a859b68925b7c8615bf3bf955f0c5db7558818fc9177c2a5d5f588b848bb15094d5f2d1f9a92693204ddc753ef25411d328e8c7f755f93184b54 SHA512 b5fb24a525c10bbb1f82074b9637e4ddd68ec8bd80c3676f326f4be41a81643cb539c13123447895f6a3639d8938f70f009de31752eb5753ca1dc3dd162d9f92
DIST Django-3.2.18.tar.gz 9848949 BLAKE2B cf42d306d506addb43f725d5896be7bba41e37633fab0173d9e0bc76894b7c5a26fa945edb85e33f7b356d1d36b3ea9e7c85b5ec6efda5541639bc425230e8ff SHA512 dbcf8daa4edf3666bfcb366b09e1c3de12a4176770ab2e6cd22b459ff77aa4cdbd72c445f53e7b23a907f663dc37b07c15d5d0d67e63fdec98eb4832dcc57d6d
DIST Django-3.2.19.checksum.txt 2558 BLAKE2B dafc8f9b47686b96aca4e3c48fd7bac91ce26f5439439f5799cdbfd892120797cdf99dcf99ede62bc825f4e2475691b6235c9fd077da1cc3b2a946933798f207 SHA512 4d1596e83a064b02abf0c00ec7f9f134be1cb9a77e61016b5a3370b5c286ebb667c1a29b678a403b98f6d8b5488dd16c50297db7026d46e913d2793996aa1171
DIST Django-3.2.19.tar.gz 9832772 BLAKE2B 3b18fe5edf258b71111bbd34d55c5006d4f399155841549e02d4e256a2710bd1c22408d6cb1edea041aaf3239c709d4c51695e5a42a5440339714f0e6c3d4824 SHA512 25a611b4479718b866b9f7b9247d6ada1f20c9118d17735f07fe3ae2e7092bee3655c1733c5c244b2e7f5ab04f6d5cc7fab94ca33d2426e281581554a64582dc
DIST Django-4.0.10.checksum.txt 2563 BLAKE2B 1ec93751204e80d75f5f4f15086cfd9aabe65e392359f82edb234f2b86802bd1078e00575379c1956dfca8e6c60ddc6209079ae7e99450aa000b22c3312a89f4 SHA512 67b335f184ce02395efba3a4bec7d8087735ef8816eda70867faf9c02242c11c95f30fc36db6abd30996098dd567ef53f6dd467567c5405f34cb2bff7cd2a23c
DIST Django-4.0.10.tar.gz 10430363 BLAKE2B d36aefd5d00023e5c4e34dda2b283e9a82d9e3b82576ce00cef7d9b75837ffdbf56327ad21ccefb02b79e8db93f12cf850541f4cb1d01b3dd28bdea0c73cb9d6 SHA512 04d1b207af21067c22c120486ff57ea602b3436adf1871f691735825afb30c3ed62f1cbc98d92fa70e9a818bcf50db70d949ab0c460f48f6027b75df9eba56c7
DIST Django-4.1.7.checksum.txt 2554 BLAKE2B 5a82eca5edb5b5d90c629c6d42414725b32ed55fc137cfb3fc9c5bfd392dc0fcc3f6b99eea64a16a88002a521bf910464a6fe11d9079d68e056acded3432be38 SHA512 4244abf4e81aec1f8daa7815f57483963e94cf67571f0c2f6ab67507515c7f6f72f86412a17c8e1e73170e1ed7d3d4503c5adba36c66d0b8f015350c81348116
Expand Down
110 changes: 110 additions & 0 deletions dev-python/django/django-3.2.19.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,110 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE='sqlite?,threads(+)'

inherit bash-completion-r1 distutils-r1 optfeature verify-sig

DESCRIPTION="High-level Python web framework"
HOMEPAGE="
https://www.djangoproject.com/
https://github.com/django/django/
https://pypi.org/project/Django/
"
SRC_URI="
https://media.djangoproject.com/releases/$(ver_cut 1-2)/${P^}.tar.gz
verify-sig? ( https://media.djangoproject.com/pgp/${P^}.checksum.txt )
"
S="${WORKDIR}/${P^}"

LICENSE="BSD"
# admin fonts: Roboto (media-fonts/roboto)
LICENSE+=" Apache-2.0"
# admin icons, jquery, xregexp.js
LICENSE+=" MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
IUSE="doc sqlite test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-python/asgiref-3.3.4[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
$(python_gen_impl_dep sqlite)
${RDEPEND}
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pillow[webp,${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/selenium[${PYTHON_USEDEP}]
dev-python/tblib[${PYTHON_USEDEP}]
sys-devel/gettext
)
verify-sig? ( >=sec-keys/openpgp-keys-django-20201201 )
"

PATCHES=(
"${FILESDIR}"/${PN}-3.1-bashcomp.patch
# TODO: merge these two when older versions are gone
"${FILESDIR}"/django-3.2.18-py311.patch
"${FILESDIR}"/django-3.2.19-py311.patch
)

distutils_enable_sphinx docs --no-autodoc

VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/django.asc

src_unpack() {
if use verify-sig; then
cd "${DISTDIR}" || die
verify-sig_verify_signed_checksums \
"${P^}.checksum.txt" sha256 "${P^}.tar.gz"
cd "${WORKDIR}" || die
fi

default
}

python_prepare_all() {
# Fails because of warnings
sed -i 's/test_dumpdata_proxy_with_concrete/_&/' tests/fixtures/tests.py || die
# TODO: this suddenly started failing
sed -i -e 's:test_custom_fields:_&:' tests/inspectdb/tests.py || die

distutils-r1_python_prepare_all
}

python_test() {
# Tests have non-standard assumptions about PYTHONPATH,
# and don't work with ${BUILD_DIR}/lib.
PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite -v2 ||
die "Tests fail with ${EPYTHON}"
}

python_install_all() {
newbashcomp extras/django_bash_completion ${PN}-admin
bashcomp_alias ${PN}-admin django-admin.py

distutils-r1_python_install_all
}

pkg_postinst() {
optfeature_header "Additional Backend support can be enabled via:"
optfeature "MySQL backend support" dev-python/mysqlclient
optfeature "PostgreSQL backend support" dev-python/psycopg:2
optfeature_header
optfeature "GEO Django" "sci-libs/gdal[geos]"
optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
optfeature "ImageField Support" dev-python/pillow
optfeature "Password encryption" dev-python/bcrypt
optfeature "High-level abstractions for Django forms" dev-python/django-formtools
}
30 changes: 30 additions & 0 deletions dev-python/django/files/django-3.2.19-py311.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From 0981a4bc273e2a87ad10c602d9547e006e06d8dd Mon Sep 17 00:00:00 2001
From: Mariusz Felisiak <[email protected]>
Date: Fri, 7 Apr 2023 11:07:54 +0200
Subject: [PATCH] Refs #34118 -- Fixed CustomChoicesTests.test_uuid_unsupported
on Python 3.11.4+.

https://github.com/python/cpython/commit/5342f5e713e0cc45b6f226d2d053a8cde1b4d68e

Follow up to 38e63c9e61152682f3ff982c85a73793ab6d3267.
---
tests/model_enums/tests.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/model_enums/tests.py b/tests/model_enums/tests.py
index ffc199ce42..c4ca6c91d7 100644
--- a/tests/model_enums/tests.py
+++ b/tests/model_enums/tests.py
@@ -259,7 +259,7 @@ class CustomChoicesTests(SimpleTestCase):
pass

def test_uuid_unsupported(self):
- msg = 'UUID objects are immutable'
- with self.assertRaisesMessage(TypeError, msg):
+ with self.assertRaises(TypeError):
+
class Identifier(uuid.UUID, models.Choices):
A = '972ce4eb-a95f-4a56-9339-68c208a76f18'
--
2.40.1

0 comments on commit 3a5885d

Please sign in to comment.